aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Sapota <marek@sapota.org>2013-06-02 23:37:38 -0700
committerMarek Sapota <marek@sapota.org>2013-06-02 23:37:38 -0700
commit9e1a5b1049f8675e0f3bf4efe3ed0a47f7f565c1 (patch)
tree94f2d9a71e7c89812acf1b68d33b834600704e02
downloadennui-9e1a5b1049f8675e0f3bf4efe3ed0a47f7f565c1.tar.gz
ennui-9e1a5b1049f8675e0f3bf4efe3ed0a47f7f565c1.tar.bz2
ennui-9e1a5b1049f8675e0f3bf4efe3ed0a47f7f565c1.zip
Add watchman ebuild
-rw-r--r--Manifest3
-rw-r--r--watchman-2.5.1.ebuild48
-rw-r--r--watchman-9999.ebuild48
3 files changed, 99 insertions, 0 deletions
diff --git a/Manifest b/Manifest
new file mode 100644
index 0000000..b9eacd2
--- /dev/null
+++ b/Manifest
@@ -0,0 +1,3 @@
+DIST watchman-2.5.1.tar.gz 134629 SHA256 58da13ddc6ad3f3b5e0c80db4a9c3331b0e6e305e219d80f201e86f77385f1d2 SHA512 0d6a1e35dc7fe6eef32ece5a62ded134807b975a7f03c6c330a311ac18727f1df4a38e0c5580ba66e6b8820a89a8227f521a7a1ed7a33832632a8c57e5c60997 WHIRLPOOL 6ffc444656cdedd58ca42bbba9e7389730e9e3d1cd33b9c9cdf8f5350fd7f269ffc0d3f32c97f68749de261d934547622d7047fb3ace578831a24b35503a2b51
+EBUILD watchman-2.5.1.ebuild 1592 SHA256 fa7ad9970af16927d31468f0f2f2ea5085e778f6532409bff53e31901f9a5fb4 SHA512 3426914fb8fb89309ea290f9aaae1699b4860c7a79fc2e243d47221d73aa2db39514bc7b3cc3ff2833c0d1db24fc7f279c851f973eb2d581f2d5e1f397a0c0cc WHIRLPOOL e6e13fa8bd42b4b93d9da243f4587f418cdd245936901ca9d073088c500c766aeddc1aad4d9183bac6870a2163d9b1406ca5b3483a7e80f1b69f4c7cf7405993
+EBUILD watchman-9999.ebuild 1592 SHA256 fa7ad9970af16927d31468f0f2f2ea5085e778f6532409bff53e31901f9a5fb4 SHA512 3426914fb8fb89309ea290f9aaae1699b4860c7a79fc2e243d47221d73aa2db39514bc7b3cc3ff2833c0d1db24fc7f279c851f973eb2d581f2d5e1f397a0c0cc WHIRLPOOL e6e13fa8bd42b4b93d9da243f4587f418cdd245936901ca9d073088c500c766aeddc1aad4d9183bac6870a2163d9b1406ca5b3483a7e80f1b69f4c7cf7405993
diff --git a/watchman-2.5.1.ebuild b/watchman-2.5.1.ebuild
new file mode 100644
index 0000000..cc8ab09
--- /dev/null
+++ b/watchman-2.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright (c) 2013 Marek Sapota
+#
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation
+# files (the "Software"), to deal in the Software without
+# restriction, including without limitation the rights to use,
+# copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following
+# conditions:
+#
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="A file watching service."
+HOMEPAGE="https://github.com/facebook/watchman"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://github.com/facebook/watchman.git"
+ SRC_URI=""
+ inherit git-2
+else
+ SRC_URI="https://github.com/facebook/watchman/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit vcs-snapshot
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/watchman-9999.ebuild b/watchman-9999.ebuild
new file mode 100644
index 0000000..cc8ab09
--- /dev/null
+++ b/watchman-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright (c) 2013 Marek Sapota
+#
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation
+# files (the "Software"), to deal in the Software without
+# restriction, including without limitation the rights to use,
+# copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following
+# conditions:
+#
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="A file watching service."
+HOMEPAGE="https://github.com/facebook/watchman"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://github.com/facebook/watchman.git"
+ SRC_URI=""
+ inherit git-2
+else
+ SRC_URI="https://github.com/facebook/watchman/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit vcs-snapshot
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"