aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/watchman/watchman-2.7.ebuild')
-rw-r--r--app-misc/watchman/watchman-2.7.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/watchman/watchman-2.7.ebuild b/app-misc/watchman/watchman-2.7.ebuild
new file mode 100644
index 0000000..a08ded8
--- /dev/null
+++ b/app-misc/watchman/watchman-2.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright (c) 2013 Marek Sapota
+#
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation
+# files (the "Software"), to deal in the Software without
+# restriction, including without limitation the rights to use,
+# copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following
+# conditions:
+#
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="A file watching service."
+HOMEPAGE="https://github.com/facebook/watchman"
+
+MAKEOPTS+=" -j1"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://github.com/facebook/watchman.git"
+ SRC_URI=""
+ inherit git-2
+else
+ SRC_URI="https://github.com/facebook/watchman/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit vcs-snapshot
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"