summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@occam.eroen.eu>2014-08-13 03:38:17 +0200
committereroen <eroen@occam.eroen.eu>2014-08-14 11:15:39 +0200
commitda870022173178815e92b5d8f16563ac8134561a (patch)
tree4f3db3a42b05cddc14c2417653560cefe01452d3
parentdfhack - remove wrong patch (diff)
downloaderoen-da870022173178815e92b5d8f16563ac8134561a.tar.gz
eroen-da870022173178815e92b5d8f16563ac8134561a.tar.bz2
eroen-da870022173178815e92b5d8f16563ac8134561a.zip
dfhack - (patch) look for dfhack.init-example in the right place
-rw-r--r--games-util/dfhack/files/dfhack-0.40.08_pre9999/11-dfhack-init-example.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-util/dfhack/files/dfhack-0.40.08_pre9999/11-dfhack-init-example.patch b/games-util/dfhack/files/dfhack-0.40.08_pre9999/11-dfhack-init-example.patch
new file mode 100644
index 0000000..55ef577
--- /dev/null
+++ b/games-util/dfhack/files/dfhack-0.40.08_pre9999/11-dfhack-init-example.patch
@@ -0,0 +1,39 @@
+dfhack.init.example
+
+From: eroen <eroen@occam.eroen.eu>
+
+
+---
+ library/CMakeLists.txt | 2 +-
+ library/Core.cpp | 4 ++++
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/library/CMakeLists.txt b/library/CMakeLists.txt
+index 50ac9f2..eac23db 100644
+--- a/library/CMakeLists.txt
++++ b/library/CMakeLists.txt
+@@ -350,7 +350,7 @@ install(FILES xml/symbols.xml
+ DESTINATION ${DFHACK_DATA_DESTINATION}) #linux: share/dfhack
+ #install the example autoexec file
+ install(FILES ../dfhack.init-example
+- DESTINATION ${DFHACK_USERDOC_DESTINATION})
++ DESTINATION ${DFHACK_DATA_DESTINATION})
+
+ install(TARGETS dfhack-run dfhack-client binpatch
+ LIBRARY DESTINATION ${DFHACK_LIBRARY_DESTINATION}
+diff --git a/library/Core.cpp b/library/Core.cpp
+index 8906f85..8ef600c 100644
+--- a/library/Core.cpp
++++ b/library/Core.cpp
+@@ -864,7 +864,11 @@ static void run_dfhack_init(color_ostream &out, Core *core)
+ if (!core->loadScriptFile(out, "dfhack.init", true))
+ {
+ core->runCommand(out, "gui/no-dfhack-init");
++#ifdef DFHACK_DATA_DESTINATION
++ core->loadScriptFile(out, DFHACK_DATA_DESTINATION "/dfhack.init-example", true);
++#else
+ core->loadScriptFile(out, "dfhack.init-example", true);
++#endif
+ }
+ }
+