summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vobject/vobject-0.9.5.ebuild')
-rw-r--r--dev-python/vobject/vobject-0.9.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/vobject/vobject-0.9.5.ebuild b/dev-python/vobject/vobject-0.9.5.ebuild
new file mode 100644
index 0000000..e2dcbfb
--- /dev/null
+++ b/dev-python/vobject/vobject-0.9.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for parsing and generating vCard and vCalendar files"
+HOMEPAGE="http://eventable.github.io/vobject/
+ https://pypi.python.org/pypi/vobject
+ https://github.com/eventable/vobject"
+SRC_URI="https://github.com/eventable/vobject/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ACKNOWLEDGEMENTS.txt README.md )
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Testing failed under ${EPYTHON}"
+}