summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2020-06-22 19:27:55 +0200
committerhaarp <main.haarp@gmail.com>2020-06-22 19:29:07 +0200
commitfe65d7781916a27417a3e9d85ca35257d6f79560 (patch)
tree46b9e422b530cfdccc04c4a8f0bca93153bcd6dd /games-rpg
parentSwitch gtk3-nocsd to ZaWertun fork (diff)
downloadhaarp-fe65d7781916a27417a3e9d85ca35257d6f79560.tar.gz
haarp-fe65d7781916a27417a3e9d85ca35257d6f79560.tar.bz2
haarp-fe65d7781916a27417a3e9d85ca35257d6f79560.zip
Re-add and update Doukutsu (Cave Story) which used to be in gamerlay
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/doukutsu-bin/Manifest2
-rw-r--r--games-rpg/doukutsu-bin/doukutsu-bin-1.01.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/games-rpg/doukutsu-bin/Manifest b/games-rpg/doukutsu-bin/Manifest
new file mode 100644
index 0000000..660d727
--- /dev/null
+++ b/games-rpg/doukutsu-bin/Manifest
@@ -0,0 +1,2 @@
+DIST linuxdoukutsu-1.01.tar.bz2 1036274 BLAKE2B e47a935a4fa6dcdb6648bd6b2647ea4b0b351db6b211c46ca7b904730f6fac56d5fe30b6f30d4650aee2f3277f4fd53b546120c74bc2d89ca3d26d0dcb4c6948 SHA512 e17049d4e5c919ccc61d9f01c71e36a77206536bb56099a3be739fe9faa7311a5aadee3a270c4f919e52db0d83a2e2075234df52dac02f1b90ef0e80b48510e5
+EBUILD doukutsu-bin-1.01.ebuild 1569 BLAKE2B 60482344f323074e9c47faec3eb167abf28dcf2be2a71f71526525b3892dc8e191176d4f4b0eaf904561bfe188e0e5369c808463681da4bd3855a2def3c21d68 SHA512 61386b40e50497d67566b9426d5354be7f4f5721fd8cdd3ccced64ced86eb3e80eb76eefa9e2f341b328194db08a64e824c3742fd3787568ce07d0810df3aaf3
diff --git a/games-rpg/doukutsu-bin/doukutsu-bin-1.01.ebuild b/games-rpg/doukutsu-bin/doukutsu-bin-1.01.ebuild
new file mode 100644
index 0000000..7c76bfc
--- /dev/null
+++ b/games-rpg/doukutsu-bin/doukutsu-bin-1.01.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Side-scrolling platformer written by StudioPixel"
+HOMEPAGE="http://www.cavestory.org"
+#SRC_URI="http://www.scibotic.com/uploads/2008/04/linuxdoukutsu-${PV}.tar.bz2"
+SRC_URI="http://www.archive.org/download/CavestorydoukutsuForLinuxV1.01/linuxdoukutsu-1.01.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="strip"
+
+RDEPEND="media-libs/libsdl[X]"
+
+S=${WORKDIR}/linuxDoukutsu-${PV}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r data DoConfig.exe
+ dodoc doc/*
+
+ exeinto /usr/share/${PN}
+ doexe doukutsu.bin
+ echo "cd /usr/share/${PN} && ./doukutsu.bin" > doukutsu || die "couldn't create wrapper?!"
+ dobin doukutsu
+
+ mv Config.dat doukutsu_Config.dat
+ touch doukutsu_Profile.dat || die "couldn't create empty Profile.dat?"
+ insinto /var/lib
+ insopts -m 666
+ doins doukutsu_Config.dat doukutsu_Profile.dat
+ dosym /var/lib/doukutsu_Config.dat /usr/share/${PN}/Config.dat
+ dosym /var/lib/doukutsu_Profile.dat /usr/share/${PN}/Profile.dat
+}
+
+pkg_postinst() {
+ elog "This port does not provide a configuration tool for Config.dat."
+ elog "The original DoConfig.exe is provided (if you can use wine),"
+ elog "or help for configuring it manually is provided in:"
+ elog "/usr/share/doc/${P}/configfileformat.txt"
+ elog ""
+ elog "If you need to back up your save file for any reason,"
+ elog "it is located at /var/lib/doukutsu_Profile.dat"
+}