summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/evhz/evhz-9999.ebuild')
-rw-r--r--sys-apps/evhz/evhz-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-apps/evhz/evhz-9999.ebuild b/sys-apps/evhz/evhz-9999.ebuild
new file mode 100644
index 0000000..b52c3bf
--- /dev/null
+++ b/sys-apps/evhz/evhz-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Show mouse refresh rate under evdev"
+HOMEPAGE="https://git.sr.ht/~iank/evhz"
+EGIT_REPO_URI="https://git.sr.ht/~iank/evhz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -o evhz evhz.c || die "gcc failed"
+}
+
+src_install() {
+ einstalldocs
+ dobin evhz
+}