summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/spotify/spotify-0.6.2.291.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/spotify/spotify-0.6.2.291.ebuild b/media-sound/spotify/spotify-0.6.2.291.ebuild
new file mode 100644
index 0000000..394d5e1
--- /dev/null
+++ b/media-sound/spotify/spotify-0.6.2.291.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+DESCRIPTION="Spotify desktop client"
+HOMEPAGE="http://www.spotify.com/"
+
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+MY_PV="${PV}.gcccc1f5.116-1"
+MY_P="${PN}-client-qt_${MY_PV}"
+
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}/"
+SRC_URI="
+ x86? ( ${SRC_BASE}${MY_P}_i386.deb )
+ amd64? ( ${SRC_BASE}${MY_P}_amd64.deb )
+ "
+
+RDEPEND="
+ dev-libs/openssl:0.9.8
+ >=media-libs/alsa-lib-1.0.14
+ >=sys-devel/gcc-4.0
+ >=sys-libs/glibc-2.6
+ >=x11-libs/qt-core-4.5
+ >=x11-libs/qt-dbus-4.5
+ >=x11-libs/qt-gui-4.5
+ >=x11-libs/qt-webkit-4.5
+ "
+
+RESTRICT="mirror strip"
+
+src_unpack() {
+ for MY_A in ${A}; do
+ unpack ${MY_A}
+ unpack ./data.tar.gz
+ done
+}
+
+src_install() {
+ mv "${WORKDIR}"/usr "${D}" || die "Install failed"
+}