summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bup/bup-9999.ebuild')
-rw-r--r--app-backup/bup/bup-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-backup/bup/bup-9999.ebuild b/app-backup/bup/bup-9999.ebuild
index f64af75..28b8786 100644
--- a/app-backup/bup/bup-9999.ebuild
+++ b/app-backup/bup/bup-9999.ebuild
@@ -3,11 +3,13 @@
# $Header: $
EAPI=4
-inherit git eutils multilib
+
+EGIT_REPO_URI="git://github.com/apenwarr/${PN}.git
+ http://github.com/apenwarr/${PN}.git"
+inherit git-2 eutils multilib
DESCRIPTION="It backs things up based on the git packfile format"
HOMEPAGE="http://github.com/apenwarr/bup"
-EGIT_REPO_URI="git://github.com/apenwarr/bup"
LICENSE="LGPL-2"
SLOT="0"
@@ -26,6 +28,10 @@ DEPEND="|| (
doc? ( app-text/pandoc )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch_user
+}
+
src_configure() {
# bup doesn't accept --build= option
./configure \