aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2017-11-23 21:40:34 +0000
committerPaul Healy <lmiphay@gmail.com>2017-11-23 21:40:34 +0000
commit5c4c78e2b413161fa17d9906a9c6154923747139 (patch)
treefbc167f90c091cbfbc547cac40bd6c6f61a542b0 /app-oam
parentfix files by ref for py3 and add python 3.5 (diff)
downloadlmiphay-5c4c78e2b413161fa17d9906a9c6154923747139.tar.gz
lmiphay-5c4c78e2b413161fa17d9906a9c6154923747139.tar.bz2
lmiphay-5c4c78e2b413161fa17d9906a9c6154923747139.zip
update deps and add python 3.5
Diffstat (limited to 'app-oam')
-rw-r--r--app-oam/glc/Manifest2
-rw-r--r--app-oam/glc/glc-9999.ebuild15
2 files changed, 14 insertions, 3 deletions
diff --git a/app-oam/glc/Manifest b/app-oam/glc/Manifest
index e3cc094..d25eac5 100644
--- a/app-oam/glc/Manifest
+++ b/app-oam/glc/Manifest
@@ -1 +1 @@
-EBUILD glc-9999.ebuild 761 SHA256 9d9b96bf840ff08ac6fed43a21d08778ad5fd8f2fbc0cfbd0901d02b3d7c4dff SHA512 29c3ae58deeb20404db31405923d6a3686e48471f56a40d6356e7a8b308b37c0778cadd9e24a334c276927fd56d730ab559cd6e9a19c6ecca9462313ac79f558 WHIRLPOOL cc8b5a7c96a29232cfe0ed3199cfe3705f27160643155b7da5be6caa0d95bdd3e239ca590ff465221e3f9c1fe9783e1377e67b7a295472d0d9a8c6346d63de9a
+EBUILD glc-9999.ebuild 998 SHA256 26658bae628b1c8cc4d67622a15db481df9e11268caf79ca8e76c220891e8c21 SHA512 c251bf7f03e084a5ad2dbf9044b002adc73288973ad2c01e1f39fa00ece8a006edf4c9b4b262130eb5d4cceb6bab8a4d90f5901c0d7730cc5e61518adf0d3d18 WHIRLPOOL 31f26c6f7c43cd7812266274fc19957da3b841c22d37b13b11a73ad6d65f1ef8443fd9167598619d9f21939ef44361a69763b82bf0ea3a0259ee3c9d73e44d8f
diff --git a/app-oam/glc/glc-9999.ebuild b/app-oam/glc/glc-9999.ebuild
index c044f6d..b23c4e5 100644
--- a/app-oam/glc/glc-9999.ebuild
+++ b/app-oam/glc/glc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_4 )
+PYTHON_COMPAT=( python3_{4,5} )
inherit distutils-r1 git-r3
@@ -18,11 +18,22 @@ IUSE="test"
RDEPEND="
${PYTHON_DEPS}
+ app-crypt/gnupg
+ app-crypt/rhash
+ app-emulation/lxc[python,${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
>=dev-python/invoke-0.21.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-misc/wget
+ sys-apps/coreutils
"
DEPEND="
- test? ( >=dev-python/coverage-4.2 >=dev-python/flake8-2.5.4 >=dev-python/mock-2.0.0 >=dev-python/pylint-1.6.5 )
+ test? (
+ >=dev-python/coverage-4.2[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.6.5[${PYTHON_USEDEP}]
+ )
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.6.3[${PYTHON_USEDEP}]
${RDEPEND}