aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-10-13 10:49:07 +0100
committerPaul Healy <lmiphay@gmail.com>2019-10-13 10:49:07 +0100
commit6a3b8cbea988ef29b3135b6a9a8ea59eb5418fad (patch)
treeefb50624cc5bede1b2f7c28762e9d14b444922bb /sys-apps
parentremove old version (diff)
downloadlmiphay-6a3b8cbea988ef29b3135b6a9a8ea59eb5418fad.tar.gz
lmiphay-6a3b8cbea988ef29b3135b6a9a8ea59eb5418fad.tar.bz2
lmiphay-6a3b8cbea988ef29b3135b6a9a8ea59eb5418fad.zip
bug fix to allow delay be specified
backport from https://github.com/dagwieers/dstat/pull/167/files Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dstat/Manifest1
-rw-r--r--sys-apps/dstat/dstat-0.7.4-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/dstat/Manifest b/sys-apps/dstat/Manifest
index 212f083..4154576 100644
--- a/sys-apps/dstat/Manifest
+++ b/sys-apps/dstat/Manifest
@@ -3,4 +3,5 @@ AUX dstat-0.7.4-skip-non-sandbox-tests.patch 661 BLAKE2B 31f98e58c8f23e3b6322de8
DIST dstat-0.7.3.tar.gz 135583 BLAKE2B c846a06b6039e49944d43cc36178fed74fd4e0e3a1a4418dbe0e5987763995eb36dff0245cfa7107d446b8ac2ea500e13980f87e97aa8e5b8d566ee188be1639 SHA512 db37cc8bb7afd235ae9088e76c4defaa4d76651b111fbfdcd0980bc96376de20d57964912799a413397a79651730503bdeb8fea5cb97ab4d6d81632f528aefd2
DIST dstat-0.7.4.tar.gz 139992 BLAKE2B c8226358956687a4f64e248ef539b431b9e394e87986366f9941df2e86f0dac3032261ec2ca9c816d3bc89afabc352bc8bc80f9ad3eaa6118fd16bd7b0f1e68e SHA512 d100223887ebd83d0fd1259436f39419a85df9002556abcfc8e4195aa63be73d85707dcd5c4fb56a979b29131485dce6e97c177fbfca08dc50bd0f92b15cc6f5
EBUILD dstat-0.7.3-r1.ebuild 865 BLAKE2B 60f79ac34d777a864ad9aaa154346323b7818e219833ff152597cf1f148f60439e19430e303b0ca3fc66c69538fde1d3744d91246fe5779644a73c77558fe52a SHA512 b4462000fcd9ff5554f6e3c5571997e0db595613efb13eaf7fe2a722a79e5115046039fd09ecac7578b661c6aec15a4180ff53f87dee51e17b3b9e11f95cfbe0
+EBUILD dstat-0.7.4-r1.ebuild 1116 BLAKE2B 05a86ea1b1e0ca81a88f6a1e8aa48542eba482c390ee1d86138a58a00cdfef0cdb54676dee6a5aeb51c135abc581436885257e2c8ff43281f3e76cafa6ada4ad SHA512 31fc2966a025223ee0a99702e40b2e3941634d92044e1463138334e232b53d383fc2351e91e7e54cbf4c7aea0ccd479c8be6dd442b6eaebc750c201de423fded
EBUILD dstat-0.7.4.ebuild 924 BLAKE2B 35517215d40ad369be6eb0be9481829cf315b3c0f5d68b573741d33d0800f8502ccdfc9e4e997adc0623a46731e94a052958422b3816e46792c852f4b0d87a5a SHA512 6ea9441461d14e9314a06e2b8d315e822f816a242ad2882dec39907269b30e460b4db711e51763c20b7a23f2c05a859a941593cbf2a1bb2277888c269b628e52
diff --git a/sys-apps/dstat/dstat-0.7.4-r1.ebuild b/sys-apps/dstat/dstat-0.7.4-r1.ebuild
new file mode 100644
index 0000000..4b3db17
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="wifi doc examples"
+REQUIRED_USE="wifi? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ wifi? (
+ ${PYTHON_DEPS}
+ net-wireless/python-wifi
+ )"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}/dstat-${PV}-skip-non-sandbox-tests.patch" )
+
+src_prepare() {
+
+ # bug fix: allow delay to be specified
+ # backport from: https://github.com/dagwieers/dstat/pull/167/files
+ sed -i -e 's; / op\.delay; // op.delay;' "dstat"
+
+ eapply_user
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_replicate_script "${ED}"/usr/bin/${PN}
+
+ einstalldocs
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}