summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/luxrays')
-rw-r--r--media-libs/luxrays/Manifest3
-rw-r--r--media-libs/luxrays/luxrays-1.2.1.ebuild50
-rw-r--r--media-libs/luxrays/luxrays-9999.ebuild49
3 files changed, 0 insertions, 102 deletions
diff --git a/media-libs/luxrays/Manifest b/media-libs/luxrays/Manifest
deleted file mode 100644
index 2ed9284..0000000
--- a/media-libs/luxrays/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST 475fbf15f0ca.tar.bz2 55751280 SHA256 ca57c34539f938bced15de5dd5ab7c97ce52df2faa43ed00ce4bb5c4359a5ea9 SHA512 57c4138bbdc55ec3be702acb4ed96b9c9d451cea07c23ec7d1ddf812c04ed653d34e1d4917079b526d218b2a0aea64128b732dbda8ff4e1655ec84a4152e6b4c WHIRLPOOL 2d2b4c62d65658a211ad28a2c9c3eae4b60cac22a1dea1a4f1ff1fa59720f432d9411af49cddad4436b9017177fbe37b4f11e76feeee37309958a6563c1ec307
-EBUILD luxrays-1.2.1.ebuild 1002 SHA256 7c06d40e1dcea72dade53c842920e4012326cddc8087a47c830b9990479a5ec6 SHA512 1e54412dbd39340065333663736f6de10d57a0b6996ce3a2a3998cfe08b537cf42bbcbad966f36ceb6e391d55c30a50bcff768add2ba1751926f23bde881de92 WHIRLPOOL 883f99d3b40f05e390f2394494687942c99fec83404b5df19a60f9d1fc05e6c042617366ce83cce5aad44e32a1290f9231499ede6bdeeb10fcb4adeaaa6da08b
-EBUILD luxrays-9999.ebuild 1085 SHA256 6a21c60994d1dc8a1bda0652f0399eb79bee6f12ad4e9c5d33e15dd1aae107e4 SHA512 e0d7b9ebb5feebe2e048461988f0e92dc9d6bf235e316367a3756b1ae54f4b20249aedb3d1c49ed823999993df24b7547cefd15afd84fef3c40acc9095e73063 WHIRLPOOL b2c60e0c9813ad8b18c97bd3157e92c3eaaf0d3ff02194056c174f279649fa0dd13b7b3cd4127cc193ac483966ea3bdef507adb4c2bd78796f1946550dcd960f
diff --git a/media-libs/luxrays/luxrays-1.2.1.ebuild b/media-libs/luxrays/luxrays-1.2.1.ebuild
deleted file mode 100644
index f96137e..0000000
--- a/media-libs/luxrays/luxrays-1.2.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-inherit cmake-utils flag-o-matic
-
-DESCRIPTION="Library to accelerate the ray intersection process by using GPUs."
-HOMEPAGE="http://www.luxrender.net"
-EHG_REVISION="475fbf15f0ca"
-SRC_URI="https://bitbucket.org/luxrender/luxrays/get/${EHG_REVISION}.tar.bz2"
-
-#S="${WORKDIR}/luxrender-luxrays-${EHG_REVISION}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND=">=dev-libs/boost-1.43
- media-libs/freeimage
- virtual/opencl
- virtual/opengl"
-
-src_unpack() {
- unpack ${A}
- mv "${WORKDIR}/luxrender-luxrays-${EHG_REVISION}" "${WORKDIR}/${P}"
-}
-
-src_configure() {
- append-flags "-fPIC"
- use debug && append-flags -ggdb
-
- mycmakeargs=( -Wno-dev )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_make luxrays
-}
-
-src_install() {
- dodoc ${S}/AUTHORS.txt
-
- insinto /usr/include
- doins -r ${S}/include/luxrays
-
- dolib.a ${BUILD_DIR}/lib/libluxrays.a
-}
diff --git a/media-libs/luxrays/luxrays-9999.ebuild b/media-libs/luxrays/luxrays-9999.ebuild
deleted file mode 100644
index 23bebad..0000000
--- a/media-libs/luxrays/luxrays-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit cmake-utils mercurial flag-o-matic
-#inherit cmake-utils flag-o-matic
-
-DESCRIPTION="Library to accelerate the ray intersection process by using GPUs \
-(this pkg provides only CPU support atm)"
-HOMEPAGE="http://www.luxrender.net"
-EHG_REPO_URI="https://bitbucket.org/luxrender/luxrays"
-#EHG_REVISION="29e1c03a4ae3"
-#SRC_URI="https://bitbucket.org/luxrender/luxrays/get/${EHG_REVISION}.tar.bz2"
-
-#S="${WORKDIR}/luxrender-luxrays-${EHG_REVISION}/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND=">=dev-libs/boost-1.43
- media-libs/freeimage
- virtual/opengl"
-
-CMAKE_IN_SOURCE_BUILD=1
-
-src_configure() {
- append-flags "-fPIC -DLUXRAYS_DISABLE_OPENCL"
- use debug && append-flags -ggdb
-
- mycmakeargs=( -DLUXRAYS_DISABLE_OPENCL=ON -Wno-dev )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_make luxrays
-}
-
-src_install() {
- dodoc AUTHORS.txt
-
- insinto /usr/include
- doins -r include/luxrays
-
- dolib.a lib/libluxrays.a
-}