summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2009-04-06 01:27:44 +0000
committermaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2009-04-06 01:27:44 +0000
commit5603e63530360fccd16b8cb3fafadb57e57d8fa4 (patch)
treed7af720e37a8d37af461c2fa57c5be996e040dbe
parentgnome-mplayer 0.9.5 ebuild added (diff)
downloadpiczu-5603e63530360fccd16b8cb3fafadb57e57d8fa4.tar.gz
piczu-5603e63530360fccd16b8cb3fafadb57e57d8fa4.tar.bz2
piczu-5603e63530360fccd16b8cb3fafadb57e57d8fa4.zip
tlenlinux 7.0.1.25 ebuild added
git-svn-id: http://piczu-overlay.googlecode.com/svn/trunk@50 0805d722-a2c2-11dd-9b86-41075523de00
-rw-r--r--net-im/tlenlinux/Manifest5
-rw-r--r--net-im/tlenlinux/tlenlinux-7.0.1.24.ebuild1
-rw-r--r--net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild75
3 files changed, 79 insertions, 2 deletions
diff --git a/net-im/tlenlinux/Manifest b/net-im/tlenlinux/Manifest
index 1d822f6..a7de549 100644
--- a/net-im/tlenlinux/Manifest
+++ b/net-im/tlenlinux/Manifest
@@ -1,3 +1,6 @@
DIST tlenlinux-7.0.1.24.bin 16096092 RMD160 3ec20e5716f1bd3f1df5f2eb251bcfc6c8160d6d SHA1 9d2d2a054b18552add5fcccdead21f323b40315e SHA256 ad1e03dd3f3c5566a45528df794e214760020826664055b35e3ebf7dc30798d8
+DIST tlenlinux-7.0.1.25.bin 16329051 RMD160 0c464dbfee5302f7a7c084213483081b55518e34 SHA1 6dca6e67956f18bc5fc48401a3670b071c1509f2 SHA256 8b086a9d00ca51c865e645ded5a2428e38ef234f788e293ce7042a0e70498fc9
DIST tlenlinux64-7.0.1.24.bin 16775233 RMD160 4c7959e908dde1c43bb3c05941d8df10b637bc0f SHA1 72df66f7c210860abce8fa161841ec9abd40e95b SHA256 9481b50b6b571ba520827c03ae97d8b4a3f559be8e572e4e2b765db3180c44bb
-EBUILD tlenlinux-7.0.1.24.ebuild 1401 RMD160 a7e717b076de0ed2dfbadd8c59b57e916560e33f SHA1 0d46985ba14162a58d83d8d8b6aebc0583a1771c SHA256 fd4ae1a48ea7f101fca3a6c0f72eeb8022d95681644649287d19fbf5ed4ada4b
+DIST tlenlinux64-7.0.1.25.bin 16950560 RMD160 ba2f0c145c26efc3354103217f0b29bb77ac6b15 SHA1 8c28275b54cb57aaea80e86258735941c8638710 SHA256 42d45a5ed3968109682dac8c6855c17c56992160395a235e79cd3332fe317d01
+EBUILD tlenlinux-7.0.1.24.ebuild 1355 RMD160 7b7504449a0640f115d2999bddbb76d3794cd3f0 SHA1 dace0b30d527734d55cbfd734081cbcbd10526b0 SHA256 0999c7e10768704083f99ae7041886d276502e0748e184ff5a84b64ef9d6f01c
+EBUILD tlenlinux-7.0.1.25.ebuild 1707 RMD160 f2d8e7e906f30e6275a86df99270c5ce11793bcd SHA1 b556334803e28fabbcf5ad231d69da3c76ecb2df SHA256 fdfea2ac2482ff9899c9b4c3779304eeaaad9f9fe00d618d115f9fa69c24fe1c
diff --git a/net-im/tlenlinux/tlenlinux-7.0.1.24.ebuild b/net-im/tlenlinux/tlenlinux-7.0.1.24.ebuild
index 2ab5b6a..711a263 100644
--- a/net-im/tlenlinux/tlenlinux-7.0.1.24.ebuild
+++ b/net-im/tlenlinux/tlenlinux-7.0.1.24.ebuild
@@ -59,5 +59,4 @@ src_install() {
# Install symlinks
dodir /usr/bin
dosym ${TLEN_DIR}/tlen /usr/bin/tlen
- dosym ${TLEN_DIR}/tlen-gdb /usr/bin/tlen-gdb
}
diff --git a/net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild b/net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild
new file mode 100644
index 0000000..99febce
--- /dev/null
+++ b/net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Tlen IM client"
+HOMEPAGE="http://tlen.pl"
+SRC_URI="
+ amd64? ( http://j.o2.pl/idi/${PN}64-${PV}.bin )
+ x86? ( http://j.o2.pl/idi/${P}.bin )"
+
+LICENSE="tlen"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="phonon"
+PROPERTIES="interactive"
+RESTRICT="strip"
+
+RDEPEND="x11-libs/qt-gui:4
+ phonon? ( x11-libs/qt-phonon:4 )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+TLEN_DIR="/opt/tlen"
+STATIC_FILES="./imageformats/* ./phonon_backend/* ./qt_libs/*"
+SHARED_FILES="tlen_libs/libgg.so tlen-bin updater"
+
+src_unpack() {
+ unpack_makeself
+ cd ${S}/data
+ # Fix RPATH
+ if use phonon; then
+ # Change RPATH
+ ./chrpath -r ${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
+ # Disable unset
+ sed -i "s:unset:# unset:" tlen
+ # Remove unneeded libs
+ rm -rf qt_libs imageformats phonon_backend
+ else
+ # Change RPATH
+ ./chrpath -r ${TLEN_DIR}/qt_libs:${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
+ ./chrpath -r ${TLEN_DIR}/qt_libs ${STATIC_FILES} > /dev/null
+ fi
+ # Desktop icon fix
+ sed -i "s:.jpg:.png:" ${S}/tlen.desktop
+}
+
+src_install() {
+ # Prepare directory
+ dodir ${TLEN_DIR}
+ # Copy data
+ cp -r data/* ${D}/${TLEN_DIR} || die "cp failed"
+ # Install desktop file
+ insinto /usr/share/applications/
+ doins tlen.desktop
+ # Install symlink
+ dodir /usr/bin
+ dosym ${TLEN_DIR}/tlen /usr/bin/tlen
+}
+
+pkg_preinst() {
+ check_license ${TLEN_DIR}/license.txt
+}
+
+pkg_postinst() {
+ ### @todo deactivate auto-update by default
+ elog "It is not recommended to use Updater plugin."
+ elog "You should deselect Updater in:,"
+ elog "\"Tlen\" -> \"Preferences\" -> \"Plugins\"."
+ elog
+}