summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2009-03-05 16:33:10 +0000
committermaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2009-03-05 16:33:10 +0000
commita73642a08be4fc2844f433f046fff30ab7621d97 (patch)
tree81716e6b05525b3f9e07013a423b7a401c898b3a
parenttlenlinux rdepend fix (diff)
downloadpiczu-a73642a08be4fc2844f433f046fff30ab7621d97.tar.gz
piczu-a73642a08be4fc2844f433f046fff30ab7621d97.tar.bz2
piczu-a73642a08be4fc2844f433f046fff30ab7621d97.zip
tlenlinux 7.0.1.18 ebuild
git-svn-id: http://piczu-overlay.googlecode.com/svn/trunk@38 0805d722-a2c2-11dd-9b86-41075523de00
-rw-r--r--net-im/tlenlinux-bin/Manifest3
-rw-r--r--net-im/tlenlinux-bin/tlenlinux-bin-7.0.1.18.ebuild43
2 files changed, 46 insertions, 0 deletions
diff --git a/net-im/tlenlinux-bin/Manifest b/net-im/tlenlinux-bin/Manifest
index 8a02f31..52a946b 100644
--- a/net-im/tlenlinux-bin/Manifest
+++ b/net-im/tlenlinux-bin/Manifest
@@ -1,3 +1,6 @@
DIST tlenlinux-7.0.1.17.bin 18857384 RMD160 67417f8409b2e9cf4862755056559f4cfe3e243f SHA1 3d970689589d4c2860b2727aa90f1e058a858513 SHA256 e9999eeb9d1a99090391cbd73b2a621f80b7034b3c7cd4212f7b84debe20c015
+DIST tlenlinux-7.0.1.18.bin 14732336 RMD160 f3ad09cc4ba315666ea001a007507c6b09b448d8 SHA1 5ecd992e9fb8e24f95eeccd045cf058adb1a8bed SHA256 0d05b75fefd83b7a953c6a9e223bea6fe869928612c82528a6be29bbf9d9d8d8
DIST tlenlinux64-7.0.1.17.bin 18312618 RMD160 6ed94f50df7657b0605df222ab1fc3fe53d34245 SHA1 93e4d4f835b42f6e4af3231b3c4697762884b6ad SHA256 7314987824c307bfcff6026712b7deb6c98ca4de33cbdd1f0b82a2ba558a9a4f
+DIST tlenlinux64-7.0.1.18.bin 15275997 RMD160 3c80e6583347f8f95c5ed9708ad80ee4e876e538 SHA1 7a46a199f1607cdbfd5566346db51af838098e70 SHA256 29ce7a33b2ed48fcb39b3f97ef61f068f1f713708cf6c0ebc45968d1ea333501
EBUILD tlenlinux-bin-7.0.1.17.ebuild 855 RMD160 e7ee91bd52ec0a7ba5c481652f2e22f295bbc014 SHA1 d2c81076de5cfe89a99c44c3020073af5afaeb3e SHA256 d08e333acc9c67bbd0dfab841dee23106ce20e194998d9313737eaa1478f63d5
+EBUILD tlenlinux-bin-7.0.1.18.ebuild 855 RMD160 e7ee91bd52ec0a7ba5c481652f2e22f295bbc014 SHA1 d2c81076de5cfe89a99c44c3020073af5afaeb3e SHA256 d08e333acc9c67bbd0dfab841dee23106ce20e194998d9313737eaa1478f63d5
diff --git a/net-im/tlenlinux-bin/tlenlinux-bin-7.0.1.18.ebuild b/net-im/tlenlinux-bin/tlenlinux-bin-7.0.1.18.ebuild
new file mode 100644
index 0000000..bf3f6ae
--- /dev/null
+++ b/net-im/tlenlinux-bin/tlenlinux-bin-7.0.1.18.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+MY_PN="tlenlinux"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tlen IM client"
+HOMEPAGE="http://tlen.pl"
+SRC_URI="
+ amd64? ( http://j.o2.pl/idi/${MY_PN}64-${PV}.bin )
+ x86? ( http://j.o2.pl/idi/${MY_P}.bin )"
+
+LICENSE="tlen"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=x11-libs/qt-core-4*
+ =x11-libs/qt-gui-4*"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack_makeself
+ check_license data/license.txt
+}
+
+src_install() {
+ local dir=/opt/tlen
+ # Prepare directory
+ dodir ${dir}
+ # Copy data
+ cp -r data/* ${D}/${dir} || die "cp failed"
+ # Install desktop file
+ insinto /usr/share/applications/
+ doins tlen.desktop
+ # Install symlinks
+ dodir /usr/bin
+ dosym ${dir}/tlen /usr/bin/tlen
+ dosym ${dir}/tlen-gdb /usr/bin/tlen-gdb
+}