summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/google-compute-engine/google-compute-engine-20191210-r1.ebuild (renamed from app-admin/google-compute-engine/google-compute-engine-20191210.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-admin/google-compute-engine/google-compute-engine-20191210.ebuild b/app-admin/google-compute-engine/google-compute-engine-20191210-r1.ebuild
index 46cbb1b..38caf97 100644
--- a/app-admin/google-compute-engine/google-compute-engine-20191210.ebuild
+++ b/app-admin/google-compute-engine/google-compute-engine-20191210-r1.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{9..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 systemd
@@ -39,10 +39,12 @@ HOMEPAGE="https://github.com/GoogleCloudPlatform/compute-image-packages"
LICENSE="Apache-2.0"
SLOT="0/${PVR}"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror"
+distutils_enable_tests pytest
+
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
dev-python/distro[${PYTHON_USEDEP}]"