summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2012-09-11 20:20:47 +0200
committerPaul Labedan <plabedan@gmail.com>2012-09-11 20:20:47 +0200
commit3903990441a40fae30750fa6a374bd4a42704759 (patch)
treef641b608fe18e86ace3d9a62727113af282e502d
parentupgrade bino to 1.4.0 (diff)
downloadplab-3903990441a40fae30750fa6a374bd4a42704759.tar.gz
plab-3903990441a40fae30750fa6a374bd4a42704759.tar.bz2
plab-3903990441a40fae30750fa6a374bd4a42704759.zip
add qt-creator-2.6.0_beta
-rw-r--r--dev-util/qt-creator/Manifest2
-rw-r--r--dev-util/qt-creator/qt-creator-2.6.0_beta.ebuild145
2 files changed, 147 insertions, 0 deletions
diff --git a/dev-util/qt-creator/Manifest b/dev-util/qt-creator/Manifest
new file mode 100644
index 0000000..962d41f
--- /dev/null
+++ b/dev-util/qt-creator/Manifest
@@ -0,0 +1,2 @@
+DIST qt-creator-2.6.0-beta-src.tar.gz 20047049 SHA256 999bc8133db8c1ae52e49f0da6d191d650bbe3e0174eb549c6f4bd1f4d169042 SHA512 5cf38e4b9599b723fc4773cd2bd49c8f3bf721f9ae6069190f3931de281e3610e795fe083ee5e0f8105eddfc670f69162d3fe4fc0963e2db6e0f5ff3a8d3eff3 WHIRLPOOL 52b62c44e53254779b7cd2df01efccb5388ad8833cf70b6a2aeecdcc6a1637a4dfc2e425ac613f0ba1728e0fca616f3ce2150bcb925e7b932b73b7e29293b4e6
+EBUILD qt-creator-2.6.0_beta.ebuild 4450 SHA256 d2011de0a10c09fd9ffe08b98a8304ba6e5bb14a9d57c1b6fd3bf38ab821c626 SHA512 adc8fa05c0808ec25e1785b634fc9e9fdd5d35836addf4a00c43617ddda7b2c23cf106184ec7c00f3460046e76d16b68cf6132bd11399c6d76dcc55e4272420d WHIRLPOOL 4c6f7f634a52fbfed971ad89d6e2df2186155bb8f21cfed797b94812401d2b1e1c63004d97c87190b5eac47e6a532a8f1dd6eead9c5281978519dd1c7bf22b48
diff --git a/dev-util/qt-creator/qt-creator-2.6.0_beta.ebuild b/dev-util/qt-creator/qt-creator-2.6.0_beta.ebuild
new file mode 100644
index 0000000..23858cd
--- /dev/null
+++ b/dev-util/qt-creator/qt-creator-2.6.0_beta.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/qt-creator-2.5.2.ebuild,v 1.4 2012/09/09 21:27:34 blueness Exp $
+
+EAPI=4
+
+LANGS="cs de es fr hu it ja pl ru sl uk zh_CN"
+
+inherit multilib eutils flag-o-matic qt4-r2
+
+DESCRIPTION="Lightweight IDE for C++ development centering around Qt"
+HOMEPAGE="http://qt.nokia.com/products/developer-tools"
+LICENSE="LGPL-2.1"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git
+ https://git.gitorious.org/${PN}/${PN}.git"
+else
+ MY_V=${PV/_/-}
+ MY_P=${PN}-${MY_V}-src
+ SRC_URI="http://origin.releases.qt-project.org/qtcreator/${MY_V}/${MY_P}.tar.gz"
+ einfo "SRC_URI ${SRC_URI}"
+ S=${WORKDIR}/${MY_P}
+fi
+
+SLOT="0"
+KEYWORDS="~amd64 ppc ppc64 ~x86"
+
+QTC_PLUGINS=(autotools:autotoolsprojectmanager bazaar cmake:cmakeprojectmanager
+ cvs fakevim git madde mercurial perforce subversion valgrind)
+IUSE="+botan-bundled debug doc examples ${QTC_PLUGINS[@]%:*}"
+
+QT_PV="4.7.4:4"
+
+CDEPEND="
+ >=x11-libs/qt-assistant-${QT_PV}[doc?]
+ >=x11-libs/qt-core-${QT_PV}[private-headers(+),ssl]
+ >=x11-libs/qt-declarative-${QT_PV}[private-headers(+)]
+ >=x11-libs/qt-gui-${QT_PV}[private-headers(+)]
+ >=x11-libs/qt-script-${QT_PV}[private-headers(+)]
+ >=x11-libs/qt-sql-${QT_PV}
+ >=x11-libs/qt-svg-${QT_PV}
+ debug? ( >=x11-libs/qt-test-${QT_PV} )
+ !botan-bundled? ( =dev-libs/botan-1.8* )
+"
+DEPEND="${CDEPEND}
+ !botan-bundled? ( virtual/pkgconfig )
+"
+RDEPEND="${CDEPEND}
+ >=sys-devel/gdb-7.2[python]
+ examples? ( >=x11-libs/qt-demo-${QT_PV} )
+"
+PDEPEND="
+ autotools? ( sys-devel/autoconf )
+ bazaar? ( dev-vcs/bzr )
+ cmake? ( dev-util/cmake )
+ cvs? ( dev-vcs/cvs )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+ valgrind? ( dev-util/valgrind )
+"
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ # disable unwanted plugins
+ for plugin in "${QTC_PLUGINS[@]#[+-]}"; do
+ if ! use ${plugin%:*}; then
+ einfo "Disabling ${plugin%:*} plugin"
+ sed -i -e "/^[[:space:]]\+plugin_${plugin#*:}/d" src/plugins/plugins.pro \
+ || die "failed to disable ${plugin} plugin"
+ fi
+ done
+
+ if use perforce; then
+ echo
+ ewarn "You have enabled the perforce plugin."
+ ewarn "In order to use it, you need to manually download the perforce client from"
+ ewarn " http://www.perforce.com/perforce/downloads/index.html"
+ echo
+ fi
+
+ # fix translations
+ sed -i -e "/^LANGUAGES/s:=.*:= ${LANGS}:" \
+ share/qtcreator/translations/translations.pro || die
+
+ if ! use botan-bundled; then
+ # identify system botan and pkg-config file
+ local botan_version=$(best_version dev-libs/botan | cut -d '-' -f3 | cut -d '.' -f1,2)
+ local lib_botan=$(pkg-config --libs botan-${botan_version})
+ einfo "Major version of system's botan library to be used: ${botan_version}"
+
+ # drop bundled libBotan. Bug #383033
+ rm -rf "${S}"/src/libs/3rdparty/botan || die
+ # remove references to bundled botan
+ sed -i -e "s:botan::" "${S}"/src/libs/3rdparty/3rdparty.pro || die
+ for x in testrunner parsertests modeldemo; do
+ sed -i -e "/botan.pri/d" "${S}"/tests/valgrind/memcheck/${x}.pro || die
+ done
+ sed -i -e "/botan.pri/d" "${S}"/src/libs/utils/utils_dependencies.pri || die
+ sed -i -e "/botan.pri/d" "${S}"/tests/manual/preprocessor/preprocessor.pro || die
+ # link to system botan
+ sed -i -e "/LIBS/s:$: ${lib_botan}:" "${S}"/qtcreator.pri || die
+ sed -i -e "s:-lBotan:${lib_botan}:" "${S}"/tests/manual/appwizards/appwizards.pro || die
+ # append botan refs to compiler flags
+ append-flags $(pkg-config --cflags --libs botan-${botan_version})
+ fi
+}
+
+src_configure() {
+ eqmake4 qtcreator.pro \
+ IDE_LIBRARY_BASENAME="$(get_libdir)" \
+ IDE_PACKAGE_MODE=true
+}
+
+src_compile() {
+ emake
+ use doc && emake docs
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}usr" install
+
+ # Install documentation
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins share/doc/qtcreator/qtcreator{,-dev}.qch
+ docompress -x /usr/share/doc/${PF}/qtcreator{,-dev}.qch
+ fi
+
+ # Install icon & desktop file
+ doicon src/plugins/coreplugin/images/logo/128/qtcreator.png
+ make_desktop_entry qtcreator 'Qt Creator' qtcreator 'Qt;Development;IDE'
+
+ # Remove unneeded translations
+ local lang
+ for lang in ${LANGS}; do
+ if ! has ${lang} ${LINGUAS}; then
+ rm "${ED}"usr/share/qtcreator/translations/qtcreator_${lang}.qm \
+ || eqawarn "Failed to remove ${lang} translation"
+ fi
+ done
+}