summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2015-08-31 09:10:35 +0200
committerPaul Labedan <plabedan@gmail.com>2015-08-31 09:10:35 +0200
commitcec92c4af1b45600eaa25a09ea2c7ffa9e9c8dd1 (patch)
tree6a04f7547aafc6a665085fc15e5a3f4f3f2a3bc5 /net-proxy
parentadd pycharm 4.5.3 (diff)
downloadplab-cec92c4af1b45600eaa25a09ea2c7ffa9e9c8dd1.tar.gz
plab-cec92c4af1b45600eaa25a09ea2c7ffa9e9c8dd1.tar.bz2
plab-cec92c4af1b45600eaa25a09ea2c7ffa9e9c8dd1.zip
add rtpproxy 2.0.0
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/rtpproxy/Manifest4
-rw-r--r--net-proxy/rtpproxy/files/rtpproxy.confd8
-rw-r--r--net-proxy/rtpproxy/files/rtpproxy.init25
-rw-r--r--net-proxy/rtpproxy/rtpproxy-2.0.0.ebuild27
4 files changed, 64 insertions, 0 deletions
diff --git a/net-proxy/rtpproxy/Manifest b/net-proxy/rtpproxy/Manifest
new file mode 100644
index 0000000..2c28bcf
--- /dev/null
+++ b/net-proxy/rtpproxy/Manifest
@@ -0,0 +1,4 @@
+AUX rtpproxy.confd 226 SHA256 0b956e60a4fb27140d88c2182537615f524e167e6b608a9c9782bbf781791e1d SHA512 e2ab3705329ffd10a8a5723ac3a07a2f98547f29b7055e1616ebbd141d6beff9c81d44579af9f3486f7835a7ac7228ecfe49cf09208438ed490843c6b100a104 WHIRLPOOL 5e77f0c1dae373deee35c6e307bceecd5879fbf15ca5c1c6e382c4f1cf390e14d5d4d5fc829d2c580c1b60bdb1da0cfe6bb901cde691146ae168ea0429438496
+AUX rtpproxy.init 510 SHA256 3a792681ab97e4e0f86dd9964688cbec09154776568be0269e6839a878f3b37b SHA512 7b9dddada1b88dc6a06d0a2a3f9d0a3cb1fa0d55950daa6af1508b9f48d13c21a22183d3524f1ba285c0a03b35f6e649017bc5959b2d85d666cb8db1af3617c4 WHIRLPOOL 645187bb5f828f911d0596980b5ab91898b1c7fa405b8d4c2e0611a6e8150eceb00d31134097c7346e53065107b1b506e91416f7fef0079adf728bc20de908a5
+DIST v2.0.0.tar.gz 1091661 SHA256 b52bf2a302a8f08c269217e5d507f3c3ba38f4b627bb7029c8dac8ec268b23c6 SHA512 d3991643e1e260890ec284a5cb0bacac012063512667215166551a1d534921caa035ab64452e2be7837b306ce4486cc604a9bb552254913f3a920d7756ad3711 WHIRLPOOL 856ce629ab444cfbf9f31ee5f844bd9c9c36c204c8c256dc5f60ec9f8ec30627e5ad4fe5dde8847d269039b6ba8df58ac33474a2dded3995bc6ce3036796c159
+EBUILD rtpproxy-2.0.0.ebuild 620 SHA256 a0fdd5ab3d1fb28e1b69fcab8edcd2f42fbba028a3f1042456b24d89460907cd SHA512 d08c246c124ab47a25c754b8fdb8c6722f5206643eeb32009821f100bb85e69efa16e8cadeef40687278e2b6a87f6a17e38cfdb06c878a7e799e4e64a6a44665 WHIRLPOOL d556d803fdc23d0aab921c68372b9f0c8d0c8aea0cdb98a088a14f91dfc9ee66bf21cce4b19efe5e42c6cb4263c7e1fa50f94048a0d88a65e08d2de3c6e815c6
diff --git a/net-proxy/rtpproxy/files/rtpproxy.confd b/net-proxy/rtpproxy/files/rtpproxy.confd
new file mode 100644
index 0000000..cb53e6d
--- /dev/null
+++ b/net-proxy/rtpproxy/files/rtpproxy.confd
@@ -0,0 +1,8 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Additional options to start rtpproxy with
+#
+# see "rtpproxy -h" for a list of options
+RTPPROXY_OPTS=""
diff --git a/net-proxy/rtpproxy/files/rtpproxy.init b/net-proxy/rtpproxy/files/rtpproxy.init
new file mode 100644
index 0000000..5e53e51
--- /dev/null
+++ b/net-proxy/rtpproxy/files/rtpproxy.init
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header$
+
+PIDFILE=/var/run/rtpproxy.pid
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting rtpproxy"
+ start-stop-daemon --start --quiet --pidfile "${PIDFILE}" \
+ --exec /usr/bin/rtpproxy \
+ -- -urtpproxy:rtpproxy -p"${PIDFILE}" ${RTPPROXY_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rtpproxy"
+ start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
+ eend $?
+}
+
diff --git a/net-proxy/rtpproxy/rtpproxy-2.0.0.ebuild b/net-proxy/rtpproxy/rtpproxy-2.0.0.ebuild
new file mode 100644
index 0000000..3d57cf6
--- /dev/null
+++ b/net-proxy/rtpproxy/rtpproxy-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Proxy server for RTP streams"
+HOMEPAGE="http://www.rtpproxy.org"
+SRC_URI="https://github.com/sippy/${PN}/archive/v${PV}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT="0"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup rtpproxy
+ enewuser rtpproxy -1 -1 /dev/null rtpproxy
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/rtpproxy.init rtpproxy
+ newconfd "${FILESDIR}"/rtpproxy.confd rtpproxy
+}