summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-19 21:22:12 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-19 21:22:12 -0400
commit752f4ec119229badc274a3019e044f8e5c82a513 (patch)
treebbbf0ea60003371127eef03f703d2727fc78e56b /gnome-extra/gtkhtml
parentadicionando gtk+-2.21.5 (diff)
downloadrubenqba-752f4ec119229badc274a3019e044f8e5c82a513.tar.gz
rubenqba-752f4ec119229badc274a3019e044f8e5c82a513.tar.bz2
rubenqba-752f4ec119229badc274a3019e044f8e5c82a513.zip
adicionando de todo
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/Manifest2
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.30.1.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/Manifest b/gnome-extra/gtkhtml/Manifest
new file mode 100644
index 0000000..11843c1
--- /dev/null
+++ b/gnome-extra/gtkhtml/Manifest
@@ -0,0 +1,2 @@
+DIST gtkhtml-3.30.1.tar.bz2 1350166 RMD160 e47734cf521bfe20ebd340162769b8c372f453e9 SHA1 e72ace1cf3461d3b01746e7ebcfef6e94124103b SHA256 70c8e2bffaff783408b847e54e9bb68f438dcd488721b9597168f88395a8f703
+EBUILD gtkhtml-3.30.1.ebuild 1635 RMD160 6dc71b7e50541a090c7c0b410f7ccdf3744220dc SHA1 0eb5a16be7e5f5dda140ae98b6a5b22352b18a79 SHA256 1924ba353a565857a939c209e6d2bc3e3a46c065068c1e1580fd45f37c25d190
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.30.1.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.30.1.ebuild
new file mode 100644
index 0000000..c4a0244
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.30.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.14"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+# Glade support is disabled, because it's install broken by design:
+# Install directories for glade are queried from gladeui-1.0.pc which doesn't
+# take our prefix into account. On the other side, there are maybe 3 to 4
+# people in the world who really need to install the Glade file, so they can
+# fix it themselves :)
+
+# We keep bonobo until we can make sure no apps in tree uses
+# the old composer code.
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ >=x11-themes/gnome-icon-theme-2.22.0
+ >=gnome-base/orbit-2
+ >=app-text/enchant-1.1.7
+ gnome-base/gconf:2
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="${G2CONF}
+ --disable-static"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
+ -i configure.ac configure || die "sed 1 failed"
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1::g' \
+ a11y/Makefile.am a11y/Makefile.in || die "sed 2 failed"
+}