summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/bamf/bamf-0.2.70.ebuild')
-rw-r--r--x11-libs/bamf/bamf-0.2.70.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/bamf/bamf-0.2.70.ebuild b/x11-libs/bamf/bamf-0.2.70.ebuild
new file mode 100644
index 0000000..7079256
--- /dev/null
+++ b/x11-libs/bamf/bamf-0.2.70.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit autotools
+
+DESCRIPTION="BAMF Application Matching Framework"
+SRC_URI="http://launchpad.net/bamf/trunk/${PV}/+download/bamf-${PV}.tar.gz"
+HOMEPAGE="https://launchpad.net/bamf"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="LGPL3"
+IUSE=""
+
+DEPEND=">=dev-lang/vala-0.11.7
+ dev-util/gtk-doc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's/vapigen/vapigen-0.12/' configure.in
+
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake || die
+# vapigen-0.12 --library=Bamf-0.2 --directory=${D}/lib/libbamf ${D}/lib/libbamf/Bamf-0.2.gir
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}