summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-proto/inputproto/inputproto-2.0.1-r1.ebuild')
-rw-r--r--x11-proto/inputproto/inputproto-2.0.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-proto/inputproto/inputproto-2.0.1-r1.ebuild b/x11-proto/inputproto/inputproto-2.0.1-r1.ebuild
new file mode 100644
index 0000000..4d17451
--- /dev/null
+++ b/x11-proto/inputproto/inputproto-2.0.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/inputproto/inputproto-2.0.1.ebuild,v 1.8 2011/03/15 21:12:16 xarthisius Exp $
+
+EAPI=3
+
+XORG_EAUTORECONF=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Input protocol headers"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="utouch"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+!<x11-libs/libXi-1.2.99"
+
+
+src_prepare() {
+ if use utouch ; then
+ epatch "${FILESDIR}/${PN}-2.0.1-xi2.1.patch"
+ fi
+ xorg-2_src_prepare
+}
+
+src_install() {
+ xorg-2_src_install
+}
+