summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2020-10-30 22:18:17 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2020-10-30 22:18:17 -0500
commitc6c3b4e4ae238c324483bfe3ff58a8d01cef9efc (patch)
tree15c3594aa008ecd64d1a39eb50d6dfd1db5420ba /sci-electronics
parentAdd net-wireless/nanovna-qt (diff)
downloadsattvik-c6c3b4e4ae238c324483bfe3ff58a8d01cef9efc.tar.gz
sattvik-c6c3b4e4ae238c324483bfe3ff58a8d01cef9efc.tar.bz2
sattvik-c6c3b4e4ae238c324483bfe3ff58a8d01cef9efc.zip
Update Digilent packages
Signed-off-by: Daniel Solano <gentoo@sattvik.com>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/digilent-adept-runtime/Manifest2
-rw-r--r--sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.20.2.ebuild72
-rw-r--r--sci-electronics/digilent-adept-utilities/Manifest2
-rw-r--r--sci-electronics/digilent-adept-utilities/digilent-adept-utilities-2.3.2.ebuild36
-rw-r--r--sci-electronics/digilent-waveforms/Manifest2
-rw-r--r--sci-electronics/digilent-waveforms/digilent-waveforms-3.14.3.ebuild61
6 files changed, 175 insertions, 0 deletions
diff --git a/sci-electronics/digilent-adept-runtime/Manifest b/sci-electronics/digilent-adept-runtime/Manifest
index 98224a0..60fd9ec 100644
--- a/sci-electronics/digilent-adept-runtime/Manifest
+++ b/sci-electronics/digilent-adept-runtime/Manifest
@@ -1,4 +1,6 @@
DIST digilent.adept.runtime_2.19.2-x86_64.tar.gz 5774526 BLAKE2B 879b28bd729ded7aa7d7840323d140d0617650d6d3537dbf54e01004d8b72e0beece7e4e6b53988460235894ec26045b24a0da8306c1542aa044058591cc25ec SHA512 2d294c01c9a6d66aaba54b04f32a2eba66a58d1e1e00f38564ee18ac7d11053a6a862575e98043631571a1d84299edb9bf860162ac171777f47c6ef8d42652ba
+DIST digilent.adept.runtime_2.20.2-x86_64.tar.gz 5848398 BLAKE2B 6c9bfbe7e9950a2484475388074cd5d159644ad44fa2f27b02896784fad787df873fb1081d04e0306854563f303bc832a1aba2be412b96e8b522820007d11e1e SHA512 9c581bc2d5b5389744a9434405bf64856976c62b350435cb69fc2cfa920d7f13f409557038c320b39b279b8ec815723d52a7d30fc58a3001d6f7e427fc0ecb3d
EBUILD digilent-adept-runtime-2.19.2-r1.ebuild 1365 BLAKE2B 93e910877866112857520f35f882ab07badac4409f95552bf7a3b94bdf0dc2cea89bfdb5d2fed9cd26554934169e627ca759d61c42f237a78a553ddae30a15ce SHA512 9ca7ce24ce4c0260383131afee713e2180b56c77346058e16e38ec3ece8bdd0671849d27ed9731f0456d8c1c5e6a62bfb74f06c785402fd796f02269564a7c5f
EBUILD digilent-adept-runtime-2.19.2.ebuild 1144 BLAKE2B 391425ff9ae89d1c673d5fddafb357c99a45429ed37ca5ed98ac1770f33647149a4c747a7a4bd3ecb3a5743ad48b51c9e7404b4687aa4e0c7c7a70d48433ce3a SHA512 384cf6593355373a8776fe573125be6f5184431f3971d9b418e9f9824359426416950fde62bbc42b98bd9ee91af56d3b763f30c01806afa8bda5a575bf70ef24
+EBUILD digilent-adept-runtime-2.20.2.ebuild 1365 BLAKE2B 93e910877866112857520f35f882ab07badac4409f95552bf7a3b94bdf0dc2cea89bfdb5d2fed9cd26554934169e627ca759d61c42f237a78a553ddae30a15ce SHA512 9ca7ce24ce4c0260383131afee713e2180b56c77346058e16e38ec3ece8bdd0671849d27ed9731f0456d8c1c5e6a62bfb74f06c785402fd796f02269564a7c5f
MISC metadata.xml 419 BLAKE2B 125ab7af072647a9c8fe7c35385c3881008a732c31bc753b3a87863a9f5119495c3373e73d6db6f69b957781a9cd2674638427bece674388c55e5214bc73a6f2 SHA512 c02093403ab20e23c01cf769177a64e2995d3594b51bcaed5083bbd9f69ac4ce35956e1015de1c4e38f42cfa4fa915a3846177434e80d228e9686e94b90c6de7
diff --git a/sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.20.2.ebuild b/sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.20.2.ebuild
new file mode 100644
index 0000000..f66a5d1
--- /dev/null
+++ b/sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.20.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+MY_PN=${PN//-/.}
+S="${WORKDIR}/${MY_PN}_${PV}-x86_64"
+
+DESCRIPTION="Allows communication with Digilent system boards"
+HOMEPAGE="https://reference.digilentinc.com/reference/software/adept/start"
+SRC_URI="https://s3-us-west-2.amazonaws.com/digilent/Software/Adept2+Runtime/${PV}/${MY_PN}_${PV}-x86_64.tar.gz"
+
+LICENSE="Digilent-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+QA_PREBUILT="*"
+RESTRICT="strip"
+
+src_install() {
+ (
+ insinto /usr/lib/digilent/adept
+ insopts -m0755
+ doins lib64/*
+ )
+
+ (
+ insinto /etc/ld.so.conf.d
+ doins digilent-adept-libraries.conf
+ )
+
+ (
+ insinto /usr/share/digilent/adept/data
+ doins data/jtscdvclist.txt
+ )
+
+ (
+ insinto /usr/share/digilent/adept/data/firmware
+ doins data/firmware/*.HEX
+ insopts -m0755
+ doins data/firmware/*.so
+ )
+
+ (
+ insinto /usr/share/digilent/adept/data/xpla3
+ doins data/xpla3/*.map
+ )
+
+ (
+ insinto /etc
+ doins digilent-adept.conf
+ )
+
+ dosbin bin64/dftdrvdtch
+
+ udev_dorules 52-digilent-usb.rules
+
+ # driver installation
+ (
+ insinto /usr
+ dolib.so ftdi.drivers_1.4.8-x86_64/lib64/libftd2xx.so.1.4.8
+ dosym libftd2xx.so.1.4.8 ${EP}/usr/lib64/libftd2xx.so.1
+ dosym libftd2xx.so.1.4.8 ${EP}/usr/lib64/libftd2xx.so
+ )
+}
diff --git a/sci-electronics/digilent-adept-utilities/Manifest b/sci-electronics/digilent-adept-utilities/Manifest
index 20719bf..dae2e42 100644
--- a/sci-electronics/digilent-adept-utilities/Manifest
+++ b/sci-electronics/digilent-adept-utilities/Manifest
@@ -1,3 +1,5 @@
DIST digilent.adept.utilities_2.2.1-x86_64.tar.gz 494672 BLAKE2B 6d9b030c0addedd28117a9d7f547d0aba0ee2df2607e0230aabe4a3aebbd6da990907bdcc3ef42f2456c1ef4adc9daa0188158091e0f208013899322c3800e8d SHA512 57a505e2fe03fcab5d1715cce321d1494bd0ce1433a9a7750d4e7aa38658b60851b1cdc726965839bd8f1333b4132509e4b5ec8256fccd988d236d8ce43534bb
+DIST digilent.adept.utilities_2.3.2-x86_64.tar.gz 503726 BLAKE2B da5656f91674b64dbc2c079107efc4bae259f15a7b5120205b79e734d2112e68f863df6853e5783e1cfc8a74dfd24dcbeb9b5c9b30b148edd74f4e8673d90877 SHA512 3636e70803d2b08e240442cc740cf1b999cd139f63d379b6b5f01651df62937028f5c4a83dcb4434460d8ebf097a3c6196fc33fc3391a7ce8f61df2fd858af3e
EBUILD digilent-adept-utilities-2.2.1.ebuild 749 BLAKE2B 76e10dbd1123cac019bd46d04864ca272bc02b6950ae4d24d81125517b5e7c026f837fc9f47fc4b9f1b2190d9ec337dda2a4fc78063e6502fdf594057dcbd757 SHA512 9a97e877473f557f4f1c2123271af1ab11951449f51ff05e8093d571965f002ee281bce3b50b100edac0f99ae8b3ab31b6c8a0817fbaf1ebff16ee95b7b871ae
+EBUILD digilent-adept-utilities-2.3.2.ebuild 749 BLAKE2B 76e10dbd1123cac019bd46d04864ca272bc02b6950ae4d24d81125517b5e7c026f837fc9f47fc4b9f1b2190d9ec337dda2a4fc78063e6502fdf594057dcbd757 SHA512 9a97e877473f557f4f1c2123271af1ab11951449f51ff05e8093d571965f002ee281bce3b50b100edac0f99ae8b3ab31b6c8a0817fbaf1ebff16ee95b7b871ae
MISC metadata.xml 436 BLAKE2B 36b4ac025d77ca699458b04d528f100072c05ca28e31628623878e115ac3b01e5d9b4392bb3b947d380c85a13939003eb0391465e4e91cecc0a2fc8ed219d253 SHA512 529548e9a69eead5a2c163e6d565ddaee0281d9637ab20fc5323ff40b0903e9113a75a2ef854c6040c0b86c7c0924a2fccb3e13086d046fb7949782c223a1cad
diff --git a/sci-electronics/digilent-adept-utilities/digilent-adept-utilities-2.3.2.ebuild b/sci-electronics/digilent-adept-utilities/digilent-adept-utilities-2.3.2.ebuild
new file mode 100644
index 0000000..a60d4af
--- /dev/null
+++ b/sci-electronics/digilent-adept-utilities/digilent-adept-utilities-2.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+MY_PN=${PN//-/.}
+S="${WORKDIR}/${MY_PN}_${PV}-x86_64"
+
+DESCRIPTION="Command line utilities for managing Digilent devices"
+HOMEPAGE="https://reference.digilentinc.com/reference/software/adept/start"
+SRC_URI="https://s3-us-west-2.amazonaws.com/digilent/Software/AdeptUtilities/${PV}/${MY_PN}_${PV}-x86_64.tar.gz"
+
+LICENSE="Digilent-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sci-electronics/diligent-adept-runtime"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+QA_PREBUILT="*"
+RESTRICT="strip"
+
+src_install() {
+ dobin bin64/*
+
+ (
+ insinto /usr/share/digilent/dsumecfg/bitstreams
+ doins bitstreams/dsumecfg/*.bit
+ )
+
+ doman man/*
+}
diff --git a/sci-electronics/digilent-waveforms/Manifest b/sci-electronics/digilent-waveforms/Manifest
index 40d2593..27d9431 100644
--- a/sci-electronics/digilent-waveforms/Manifest
+++ b/sci-electronics/digilent-waveforms/Manifest
@@ -1,3 +1,5 @@
DIST digilent.waveforms_3.10.9_amd64.deb 37570876 BLAKE2B 7d4e88111d846ddac0b6d6c5e2cb6147022c32d8e9219d766308640dba5c0656a91ee427f1e592ecb05a2208f6e62c00cfd904f453cbbf73c25304d20a7d23a9 SHA512 61905f7a92060829a882f6c93c1610929de7f0daa3f615c058732e43284547ba0343fe03ad57b478a3559becf9dd15ccc0e9a4e84293d53d44a276adc13c3703
+DIST digilent.waveforms_3.14.3_amd64.deb 40750148 BLAKE2B 15c245de8d33a25d894138db76af2f0eaa14fe0dabed5fd093e947a3efc4b4f915dd7e592240bff4031c8b346819cd19cbd0e390a4733ad9d630e2d56fb0d19d SHA512 f6aadb22ae0a7c82bc3e49ab8d48fcdab31b083d577a87c6a22173ac7cf7dbc99e58c43936de042236fe996416f54db8afce93a8c84b6bb79a206df9f0f55202
EBUILD digilent-waveforms-3.10.9.ebuild 1241 BLAKE2B eec80e9287adba79d816d70d7ccb70f213c1f10419deacca917168d71921f4d18b90586b265e7ee5258c88a9eaf6d99e1180e65d98c94497237101cd13938058 SHA512 7867b20ebc18181c5e9b5d9bc94bb76fb784bc60b39367bce0d672bdb38aa0ebf71dd686931728033a4acf69f692ae3d5b75613fc43fbc13be3cae9b549db57a
+EBUILD digilent-waveforms-3.14.3.ebuild 1241 BLAKE2B eec80e9287adba79d816d70d7ccb70f213c1f10419deacca917168d71921f4d18b90586b265e7ee5258c88a9eaf6d99e1180e65d98c94497237101cd13938058 SHA512 7867b20ebc18181c5e9b5d9bc94bb76fb784bc60b39367bce0d672bdb38aa0ebf71dd686931728033a4acf69f692ae3d5b75613fc43fbc13be3cae9b549db57a
MISC metadata.xml 445 BLAKE2B 97d918b07c13f3d93a2ae1dc237ba3236e8e948af24bca3070807efc5772e6485d552a96b92e31682e4488284a0bfbdef843efadbd455c28ed21ec6f4ea4d41a SHA512 b2e383349d8686cf4536a1da579a02216813251560416a709731e7a6aa301460317f08ba7fd35ab4b84ee3df70c9d0bc811e1cbf9ab2ea0d4b5a4dbbaa456d79
diff --git a/sci-electronics/digilent-waveforms/digilent-waveforms-3.14.3.ebuild b/sci-electronics/digilent-waveforms/digilent-waveforms-3.14.3.ebuild
new file mode 100644
index 0000000..548a282
--- /dev/null
+++ b/sci-electronics/digilent-waveforms/digilent-waveforms-3.14.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN//-/.}
+
+DESCRIPTION="Digilent WaveForms Application, Runtime, and SDK"
+HOMEPAGE="https://reference.digilentinc.com/reference/software/adept/start"
+SRC_URI="https://s3-us-west-2.amazonaws.com/digilent/Software/Waveforms2015/${PV}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="Digilent-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtscript:5[scripttools]
+ sci-electronics/digilent-adept-runtime"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+QA_PREBUILT="*"
+RESTRICT="strip"
+
+src_unpack() {
+ default
+ mkdir "${S}"
+ cd "${S}"
+ tar xzf "${WORKDIR}/data.tar.gz" \
+ --exclude="usr/share/lintian" \
+ --exclude="usr/lib/digilent/waveforms/qtlibs"
+}
+
+src_install() {
+ dobin usr/bin/*
+
+ doheader -r usr/include/digilent
+
+ dolib.so usr/lib/libdwf.so
+ dolib.so usr/lib/libdwf.so.3
+ dolib.so usr/lib/libdwf.so.3.10.9
+
+ for manpage in usr/share/man/man1/*.gz; do
+ gunzip "$manpage"
+ doman "${manpage/.gz/}"
+ done
+
+ (
+ insinto /usr/lib
+ doins -r usr/lib/digilent
+
+ chmod +x "${ED}/usr/lib/digilent/waveforms/waveforms"
+ chmod +x "${ED}/usr/lib/digilent/waveforms/waveforms.sh"
+ )
+
+ (
+ insinto /usr/share
+ doins -r usr/share/digilent
+ )
+}