summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/elogind/elogind-252.9999.ebuild')
-rw-r--r--sys-auth/elogind/elogind-252.9999.ebuild33
1 files changed, 30 insertions, 3 deletions
diff --git a/sys-auth/elogind/elogind-252.9999.ebuild b/sys-auth/elogind/elogind-252.9999.ebuild
index 9098afd..12e692a 100644
--- a/sys-auth/elogind/elogind-252.9999.ebuild
+++ b/sys-auth/elogind/elogind-252.9999.ebuild
@@ -109,6 +109,16 @@ src_install() {
pkg_postinst() {
udev_reload
+ if ! use pam; then
+ ewarn "${PN} will not be managing user logins/seats without USE=\"pam\"!"
+ ewarn "In other words, it will be useless for most applications."
+ ewarn
+ fi
+ if ! use policykit; then
+ ewarn "loginctl will not be able to perform privileged operations without"
+ ewarn "USE=\"policykit\"! That means e.g. no suspend or hibernate."
+ ewarn
+ fi
if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
elog "elogind is currently started from boot runlevel."
elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then
@@ -118,10 +128,27 @@ pkg_postinst() {
ewarn "# rc-update del elogind default"
ewarn "# rc-update add elogind boot"
else
- ewarn "elogind is currently not started from any runlevel."
- ewarn "You may add it to the boot runlevel by:"
- ewarn "# rc-update add elogind boot"
+ elog "elogind is currently not started from any runlevel."
+ elog "You may add it to the boot runlevel by:"
+ elog "# rc-update add elogind boot"
+ elog
+ elog "Alternatively, you can leave elogind out of any"
+ elog "runlevel. It will then be started automatically"
+ if use pam; then
+ elog "when the first service calls it via dbus, or"
+ elog "the first user logs into the system."
+ else
+ elog "when the first service calls it via dbus."
+ fi
fi
+
+ for version in ${REPLACING_VERSIONS}; do
+ if ver_test "${version}" -lt 252.9; then
+ elog "Starting with release 252.9 the sleep configuration is now done"
+ elog "in the /etc/elogind/sleep.conf. Should you use non-default sleep"
+ elog "configuration remember to migrate those to new configuration file."
+ fi
+ done
}
pkg_postrm() {