summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-units/systemd-units-9999.ebuild')
-rw-r--r--sys-apps/systemd-units/systemd-units-9999.ebuild30
1 files changed, 9 insertions, 21 deletions
diff --git a/sys-apps/systemd-units/systemd-units-9999.ebuild b/sys-apps/systemd-units/systemd-units-9999.ebuild
index 30c8b5e..e1eceba 100644
--- a/sys-apps/systemd-units/systemd-units-9999.ebuild
+++ b/sys-apps/systemd-units/systemd-units-9999.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=3
-inherit systemd-local
+inherit systemd
DESCRIPTION="Service files for sys-apps/systemd"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd http://en.gentoo-wiki.com/wiki/Systemd"
@@ -21,34 +21,22 @@ DEPEND=""
src_install() {
if use basic; then
- doservices "${FILESDIR}"/services-basic/*
- doservices "${DISTDIR}/sshd.service"
- doservices "${DISTDIR}/sshd.socket"
- doservices "${DISTDIR}/sshd@.service"
+ systemd_dounit "${FILESDIR}"/services-basic/*
+ systemd_dounit "${DISTDIR}/sshd.service"
+ systemd_dounit "${DISTDIR}/sshd.socket"
+ systemd_dounit "${DISTDIR}/sshd@.service"
fi
if use server; then
- doservices "${FILESDIR}"/services-server/*
- dotmpfiles "${FILESDIR}"/tmpfiles-server/*
+ systemd_dounit "${FILESDIR}"/services-server/*
+ systemd_dotmpfilesd "${FILESDIR}"/tmpfiles-server/*
fi
if use desktop; then
- doservices "${FILESDIR}"/services-desktop/*
+ systemd_dounit "${FILESDIR}"/services-desktop/*
fi
if use sysv; then
- doservices "${FILESDIR}"/services-sysv/*
+ systemd_dounit "${FILESDIR}"/services-sysv/*
fi
}
-
-pkg_postinst() {
- elog "NetworkManager.service has been removed, because it is included"
- elog "upstream. Emerge >=net-misc/networkmanager-0.8.2 if you use"
- elog "NetworkManager."
- elog
- elog "The gdm.service has been removed in favour of gdm@.service. Please"
- elog "remove the stale symlinks 'display-manager.service' and"
- elog "'graphical.target.wants/gdm.service' under '/etc/systemd/system'"
- elog "if you had them enabled, and enable the new service file with"
- elog " systemctl enable gdm@.service"
-}