summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWojciech Dzierżanowski <wojciech.dzierzanowski@gmail.com>2010-10-24 16:07:50 +0200
committerWojciech Dzierżanowski <wojciech.dzierzanowski@gmail.com>2010-10-24 16:07:50 +0200
commitbf81a291fa6163284f7ecb3772d39168148cacbb (patch)
tree0c4321c3dcd6196f7a98d4bf8038a9e00804eb4d /media-gfx/darktable/darktable-0.6.ebuild
parentInclude version in distfile name (diff)
downloadwdzierzan-bf81a291fa6163284f7ecb3772d39168148cacbb.tar.gz
wdzierzan-bf81a291fa6163284f7ecb3772d39168148cacbb.tar.bz2
wdzierzan-bf81a291fa6163284f7ecb3772d39168148cacbb.zip
New ebuild for darkroom
Diffstat (limited to 'media-gfx/darktable/darktable-0.6.ebuild')
-rw-r--r--media-gfx/darktable/darktable-0.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-gfx/darktable/darktable-0.6.ebuild b/media-gfx/darktable/darktable-0.6.ebuild
new file mode 100644
index 0000000..250c7b3
--- /dev/null
+++ b/media-gfx/darktable/darktable-0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="A virtual lighttable and darkroom for photographers"
+HOMEPAGE="http://darktable.sourceforge.net/index.shtml"
+SRC_URI="http://downloads.sourceforge.net/project/darktable/darktable/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+lensfun openmp gnome-keyring static-libs"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/dbus-glib
+ gnome-base/gconf
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ media-gfx/exiv2
+ media-libs/jpeg
+ media-libs/lcms
+ lensfun? ( >=media-libs/lensfun-0.2.3 )
+ media-libs/libpng
+ media-libs/openexr
+ media-libs/tiff
+ net-misc/curl
+ x11-libs/cairo
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static ) \
+ $(use_enable gnome-keyring gkeyring ) \
+ $(use_enable openmp ) \
+ $(use_enable lensfun ) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS
+}