summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2011-02-20 19:07:01 +0200
committerIskren Slavov <iskren.s@gmail.com>2011-02-20 19:07:01 +0200
commit65ed46fd237734f79bcb1ee06dc9d32ff12e7ef9 (patch)
tree648fd220a042893880c371fd4a50dcb35430c2d2 /sys-libs/libuser/libuser-0.57.1.ebuild
parentCleanup old liferea versions. (diff)
downloadwish-65ed46fd237734f79bcb1ee06dc9d32ff12e7ef9.tar.gz
wish-65ed46fd237734f79bcb1ee06dc9d32ff12e7ef9.tar.bz2
wish-65ed46fd237734f79bcb1ee06dc9d32ff12e7ef9.zip
Updated libuser to 0.57.1.
Diffstat (limited to 'sys-libs/libuser/libuser-0.57.1.ebuild')
-rw-r--r--sys-libs/libuser/libuser-0.57.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-libs/libuser/libuser-0.57.1.ebuild b/sys-libs/libuser/libuser-0.57.1.ebuild
new file mode 100644
index 0000000..4468b3b
--- /dev/null
+++ b/sys-libs/libuser/libuser-0.57.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+inherit base eutils
+
+DESCRIPTION="The libuser library implements a standardized interface for manipulating and administering user and group accounts."
+HOMEPAGE="https://fedorahosted.org/libuser"
+SRC_URI="https://fedorahosted.org/releases/l/i/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="ldap +popt sasl selinux"
+COMMON_DEPEND="dev-libs/glib:2
+ ldap? ( net-nds/openldap )
+ popt? ( dev-libs/popt )
+ sasl? ( dev-libs/cyrus-sasl )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="app-text/linuxdoc-tools
+ sys-devel/bison
+ sys-devel/gettext
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ cd "${S}"
+ econf $(use_with ldap) $(use_with popt) $(use_with sasl) \
+ $(use_with selinux) --with-python
+}