summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tty-clock/tty-clock-0_p20141225.ebuild')
-rw-r--r--app-misc/tty-clock/tty-clock-0_p20141225.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/tty-clock/tty-clock-0_p20141225.ebuild b/app-misc/tty-clock/tty-clock-0_p20141225.ebuild
new file mode 100644
index 0000000..1c82ed0
--- /dev/null
+++ b/app-misc/tty-clock/tty-clock-0_p20141225.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit vcs-snapshot toolchain-funcs eutils
+
+DESCRIPTION="Analog clock in ncurses"
+HOMEPAGE="https://github.com/xorg62/tty-clock"
+GIT_COMMIT=4e6b4cae8aad23bd52ab17134ea32ef5619fcfb0
+SRC_URI="https://github.com/xorg62/tty-clock/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ INSTALLPATH="/usr/bin/" \
+ install
+ dodoc README
+}