summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-11 11:29:54 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-11 11:29:54 +0000
commit6387c78bdade59dbd0893302cb41eb33957065cd (patch)
treea091aeb863d4584e66f1ed97e82df8eef1bd0c1b
parentInitial import. Needed for sci-astronomy/skycat (diff)
downloadgentoo-2-6387c78bdade59dbd0893302cb41eb33957065cd.tar.gz
gentoo-2-6387c78bdade59dbd0893302cb41eb33957065cd.tar.bz2
gentoo-2-6387c78bdade59dbd0893302cb41eb33957065cd.zip
Version bump, reverting some Debian changes breaking standard DESTDIR.
(Portage version: 2.1.4.4)
-rw-r--r--media-sound/audtty/ChangeLog8
-rw-r--r--media-sound/audtty/audtty-0.1.8.ebuild47
-rw-r--r--media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch30
3 files changed, 84 insertions, 1 deletions
diff --git a/media-sound/audtty/ChangeLog b/media-sound/audtty/ChangeLog
index a42e1e4c4e52..5dac2671445d 100644
--- a/media-sound/audtty/ChangeLog
+++ b/media-sound/audtty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audtty
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audtty/ChangeLog,v 1.14 2008/04/11 11:13:19 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audtty/ChangeLog,v 1.15 2008/04/11 11:29:53 drac Exp $
+
+*audtty-0.1.8 (11 Apr 2008)
+
+ 11 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ +files/audtty-0.1.8-cc-and-destdir.patch, +audtty-0.1.8.ebuild:
+ Version bump, reverting some Debian changes breaking standard DESTDIR.
11 Apr 2008; Samuli Suominen <drac@gentoo.org> audtty-0.1.7.ebuild:
Fixed invalid depend, pkgconfig is only required when building. Marked amd64
diff --git a/media-sound/audtty/audtty-0.1.8.ebuild b/media-sound/audtty/audtty-0.1.8.ebuild
new file mode 100644
index 000000000000..abc7856d1f46
--- /dev/null
+++ b/media-sound/audtty/audtty-0.1.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audtty/audtty-0.1.8.ebuild,v 1.1 2008/04/11 11:29:53 drac Exp $
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Control Audacious from the command line with a friendly ncurses interface"
+HOMEPAGE="http://audtty.alioth.debian.org"
+SRC_URI="http://${PN}.alioth.debian.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ >=media-sound/audacious-1.4.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fixing Debian fsck up.
+ epatch "${FILESDIR}"/${P}-cc-and-destdir.patch
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ econf
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ elog "In order to run audtty over ssh or on a seperate TTY locally you need"
+ elog "to download and run the following script in a terminal on your desktop:"
+ elog ""
+ elog "http://${PN}.alioth.debian.org/dbus.sh"
+ elog ""
+ elog "Once run you will need to add ~/.dbus-session to your ~/.bashrc file."
+}
diff --git a/media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch b/media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch
new file mode 100644
index 000000000000..255952c61e55
--- /dev/null
+++ b/media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch
@@ -0,0 +1,30 @@
+diff -ur audtty-0.1.8.orig/Makefile.in audtty-0.1.8/Makefile.in
+--- audtty-0.1.8.orig/Makefile.in 2008-02-06 04:16:47.000000000 +0200
++++ audtty-0.1.8/Makefile.in 2008-04-11 14:24:32.000000000 +0300
+@@ -20,18 +20,18 @@
+ all: audtty
+
+ audtty: ${BINS}
+- gcc -Wall -lncurses -laudclient ${LDFLAGS} -o audtty $(BINS)
++ $(CC) -Wall -lncurses -laudclient ${LDFLAGS} -o audtty $(BINS)
+
+ .c.o:
+- gcc -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
++ $(CC) -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
+
+ install: audtty
+- mkdir -p ${bindir}
+- install -m 0755 audtty ${bindir}/audtty
+- mkdir -p ${mandir}
+- install -m 0644 audtty.1 ${mandir}/audtty.1
+- mkdir -p ${sysconfdir}
+- install -m 0644 audtty.conf ${sysconfdir}/audtty.conf
++ mkdir -p $(DESTDIR)${bindir}
++ install -m 0755 audtty $(DESTDIR)${bindir}/audtty
++ mkdir -p $(DESTDIR)${mandir}
++ install -m 0644 audtty.1 $(DESTDIR)${mandir}/audtty.1
++ mkdir -p $(DESTDIR)${sysconfdir}
++ install -m 0644 audtty.conf $(DESTDIR)${sysconfdir}/audtty.conf
+
+ uninstall:
+ rm ${bindir}/audtty || false