summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-20 20:33:37 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-20 20:33:37 +0000
commitbc116e3daaa44955d0c3938491aabb286bbce307 (patch)
tree2c48a13a323f9b5b167cca76d6a5a3d1e1baee18 /app-admin/ide-smart
parentversion bump; cleanup patch from Christian Birchinger via bug #337304 (diff)
downloadgentoo-2-bc116e3daaa44955d0c3938491aabb286bbce307.tar.gz
gentoo-2-bc116e3daaa44955d0c3938491aabb286bbce307.tar.bz2
gentoo-2-bc116e3daaa44955d0c3938491aabb286bbce307.zip
Do away with the entire Makefile. Keep upstream -Wall. Respect LDFLAGS (bug #336253). Remove empty DEPEND.
(Portage version: 2.2_rc84/cvs/Linux i686)
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/ChangeLog10
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r1.ebuild24
2 files changed, 32 insertions, 2 deletions
diff --git a/app-admin/ide-smart/ChangeLog b/app-admin/ide-smart/ChangeLog
index 9eb7ba305d53..d4050651c7ed 100644
--- a/app-admin/ide-smart/ChangeLog
+++ b/app-admin/ide-smart/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/ide-smart
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ide-smart/ChangeLog,v 1.14 2008/04/21 16:02:02 phreak Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ide-smart/ChangeLog,v 1.15 2010/09/20 20:33:37 jer Exp $
+
+*ide-smart-1.4-r1 (20 Sep 2010)
+
+ 20 Sep 2010; Jeroen Roovers <jer@gentoo.org> +ide-smart-1.4-r1.ebuild:
+ Do away with the entire Makefile. Keep upstream -Wall. Respect LDFLAGS
+ (bug #336253). Remove empty DEPEND.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
new file mode 100644
index 000000000000..4524525c6dc1
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ide-smart/ide-smart-1.4-r1.ebuild,v 1.1 2010/09/20 20:33:37 jer Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to read SMART information from harddiscs"
+HOMEPAGE="http://www.linalco.com/comunidad.html"
+SRC_URI="http://www.linalco.com/ragnar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c || die "compile"
+}
+
+src_install() {
+ dobin ide-smart || die
+ doman ide-smart.8
+ dodoc README
+}