summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-11-21 06:17:24 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-11-21 06:17:24 +0000
commit85cec418863592b1bda5770d185f727cca9ad23c (patch)
tree620fc100b6805a53666ea2dc727be07fd9fcdf81 /app-doc
parentstable x86, bug 199475 (diff)
downloadgentoo-2-85cec418863592b1bda5770d185f727cca9ad23c.tar.gz
gentoo-2-85cec418863592b1bda5770d185f727cca9ad23c.tar.bz2
gentoo-2-85cec418863592b1bda5770d185f727cca9ad23c.zip
updated to latest upstream release, fixes bug 198954
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog7
-rw-r--r--app-doc/doxygen/doxygen-1.4.2.ebuild14
-rw-r--r--app-doc/doxygen/doxygen-1.4.3-r1.ebuild18
-rw-r--r--app-doc/doxygen/doxygen-1.4.5.ebuild16
-rw-r--r--app-doc/doxygen/doxygen-1.4.6.ebuild14
-rw-r--r--app-doc/doxygen/doxygen-1.4.7.ebuild10
-rw-r--r--app-doc/doxygen/doxygen-1.5.1.ebuild10
-rw-r--r--app-doc/doxygen/doxygen-1.5.2.ebuild8
-rw-r--r--app-doc/doxygen/doxygen-1.5.3.ebuild10
-rw-r--r--app-doc/doxygen/doxygen-1.5.4.ebuild145
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.5.43
11 files changed, 204 insertions, 51 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index e37abd68e4c1..eccb8e70a579 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.132 2007/09/21 13:07:26 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.133 2007/11/21 06:17:24 nerdboy Exp $
+
+*doxygen-1.5.4 (21 Nov 2007)
+
+ 21 Nov 2007; Steve Arnold <nerdboy@gentoo.org> +doxygen-1.5.4.ebuild:
+ Updated to new version, closes bug 198954.
21 Sep 2007; Roy Marples <uberlord@gentoo.org> doxygen-1.5.3.ebuild:
Link to libiconv for FreeBSD.
diff --git a/app-doc/doxygen/doxygen-1.4.2.ebuild b/app-doc/doxygen/doxygen-1.4.2.ebuild
index 78144977f0b0..fa44e817918b 100644
--- a/app-doc/doxygen/doxygen-1.4.2.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.21 2007/07/12 19:20:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.22 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils toolchain-funcs qt3
@@ -22,24 +22,24 @@ DEPEND="media-gfx/graphviz
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# use CFLAGS and CXXFLAGS
sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
-e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
tmake/lib/linux-g++/tmake.conf
if use userland_Darwin; then
- epatch ${FILESDIR}/bsd-configure.patch
+ epatch "${FILESDIR}/bsd-configure.patch"
[[ "$MACOSX_DEPLOYMENT_TARGET" == "10.4" ]] && sed -i -e 's:-D__FreeBSD__:-D__FreeBSD__=5:' \
tmake/lib/macosx-c++/tmake.conf
fi
if use unicode; then
- epatch ${WORKDIR}/${PN}-utf8-ru.patch || die "utf8-ru patch failed"
+ epatch "${WORKDIR}/${PN}-utf8-ru.patch" || die "utf8-ru patch failed"
fi
if [ $(gcc-major-version) -eq 4 ] ; then
- epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ epatch "${FILESDIR}/${PN}-gcc4.patch" || die "gcc4 patch failed"
fi
}
@@ -83,10 +83,10 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+ dodoc LANGUAGE.HOWTO README VERSION
# pdf and html manuals
if use doc; then
diff --git a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
index 902e65b1aedf..ef260a61a859 100644
--- a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.17 2007/08/25 13:45:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.18 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils toolchain-funcs qt3
@@ -23,27 +23,27 @@ DEPEND=">=sys-apps/sed-4
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# use CFLAGS and CXXFLAGS
sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
-e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
tmake/lib/linux-g++/tmake.conf
- epatch ${FILESDIR}/${P}-cp1251.patch
- epatch ${FILESDIR}/${P}-nls.patch
+ epatch "${FILESDIR}/${P}-cp1251.patch"
+ epatch "${FILESDIR}/${P}-nls.patch"
if use userland_Darwin; then
- epatch ${FILESDIR}/bsd-configure.patch
+ epatch "${FILESDIR}/bsd-configure.patch"
[[ "$MACOSX_DEPLOYMENT_TARGET" == "10.4" ]] && sed -i -e 's:-D__FreeBSD__:-D__FreeBSD__=5:' \
tmake/lib/macosx-c++/tmake.conf
fi
if use unicode; then
- epatch ${WORKDIR}/${PN}-utf8-ru.patch || die "utf8-ru patch failed"
+ epatch "${WORKDIR}/${PN}-utf8-ru.patch" || die "utf8-ru patch failed"
fi
if [ $(gcc-major-version) -eq 4 ] ; then
- epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ epatch "${FILESDIR}/${PN}-gcc4.patch" || die "gcc4 patch failed"
fi
}
@@ -87,10 +87,10 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+ dodoc LANGUAGE.HOWTO README VERSION
# pdf and html manuals
if use doc; then
diff --git a/app-doc/doxygen/doxygen-1.4.5.ebuild b/app-doc/doxygen/doxygen-1.4.5.ebuild
index 60afe15de32d..41efeb841672 100644
--- a/app-doc/doxygen/doxygen-1.4.5.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.5.ebuild,v 1.11 2007/07/12 19:20:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.5.ebuild,v 1.12 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils toolchain-funcs qt3
@@ -23,21 +23,21 @@ DEPEND=">=sys-apps/sed-4
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# use CFLAGS and CXXFLAGS (on linux and ppc-macos)
sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
-e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
tmake/lib/{linux-g++,macosx-c++}/tmake.conf
- epatch ${FILESDIR}/doxygen-1.4.3-cp1251.patch
- epatch ${FILESDIR}/doxygen-1.4.4-darwin.patch
+ epatch "${FILESDIR}/doxygen-1.4.3-cp1251.patch"
+ epatch "${FILESDIR}/doxygen-1.4.4-darwin.patch"
if use unicode; then
- epatch ${WORKDIR}/${PN}-utf8-ru.patch || die "utf8-ru patch failed"
+ epatch "${WORKDIR}/${PN}-utf8-ru.patch" || die "utf8-ru patch failed"
fi
if [ $(gcc-major-version) -eq 4 ] ; then
- epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ "epatch ${FILESDIR}/${PN}-gcc4.patch" || die "gcc4 patch failed"
fi
}
@@ -81,10 +81,10 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+ dodoc LANGUAGE.HOWTO README VERSION
# pdf and html manuals
if use doc; then
diff --git a/app-doc/doxygen/doxygen-1.4.6.ebuild b/app-doc/doxygen/doxygen-1.4.6.ebuild
index a9fda04e74eb..70b82e76ce74 100644
--- a/app-doc/doxygen/doxygen-1.4.6.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.6.ebuild,v 1.13 2007/07/12 19:20:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.6.ebuild,v 1.14 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils toolchain-funcs qt3
@@ -26,7 +26,7 @@ EPATCH_SUFFIX="patch"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# use CFLAGS, CXXFLAGS, LDFLAGS
sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
-e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
@@ -34,16 +34,16 @@ src_unpack() {
tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf
if use unicode; then
- epatch ${WORKDIR}/${PN}-utf8-ru.patch || die "utf8-ru patch failed"
+ epatch "${WORKDIR}/${PN}-utf8-ru.patch" || die "utf8-ru patch failed"
fi
if [ $(gcc-major-version) -eq 4 ] ; then
- epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ "epatch ${FILESDIR}/${PN}-gcc4.patch" || die "gcc4 patch failed"
fi
# Consolidate patches, apply FreeBSD configure patch, codepage patch,
# qtools stuff, and patches for bugs 129142, 121770, and 129560.
- epatch ${FILESDIR}/${PV}
+ epatch "${FILESDIR}/${PV}"
}
src_compile() {
@@ -88,10 +88,10 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+ dodoc LANGUAGE.HOWTO README VERSION
# pdf and html manuals
if use doc; then
diff --git a/app-doc/doxygen/doxygen-1.4.7.ebuild b/app-doc/doxygen/doxygen-1.4.7.ebuild
index 456b91505cc7..1e2eea841b8f 100644
--- a/app-doc/doxygen/doxygen-1.4.7.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.7.ebuild,v 1.20 2007/07/12 19:20:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.7.ebuild,v 1.21 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils flag-o-matic toolchain-funcs qt3
@@ -25,11 +25,11 @@ EPATCH_SUFFIX="patch"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# still needs patch for Russian text in source files (see bug #112076)
if use unicode; then
- epatch ${WORKDIR}/${P}-utf8-ru.patch || die "utf8-ru patch failed"
+ epatch "${WORKDIR}/${P}-utf8-ru.patch" || die "utf8-ru patch failed"
fi
# use CFLAGS, CXXFLAGS, LDFLAGS
@@ -40,7 +40,7 @@ src_unpack() {
# Consolidate patches, apply FreeBSD configure patch, codepage patch,
# qtools stuff, and patches for bugs 129142, 121770, and 129560.
- epatch ${FILESDIR}/${PV}
+ epatch "${FILESDIR}/${PV}"
if is-flagq "-O3" ; then
echo
@@ -96,7 +96,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
dodoc INSTALL LANGUAGE.HOWTO README
diff --git a/app-doc/doxygen/doxygen-1.5.1.ebuild b/app-doc/doxygen/doxygen-1.5.1.ebuild
index 359bc52b881a..03f43a8f247e 100644
--- a/app-doc/doxygen/doxygen-1.5.1.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.1.ebuild,v 1.4 2007/07/12 19:20:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.1.ebuild,v 1.5 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils flag-o-matic toolchain-funcs qt3
@@ -25,11 +25,11 @@ EPATCH_SUFFIX="patch"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# still needs patch for Russian text in source files (see bug #112076)
if use unicode; then
- epatch ${WORKDIR}/${P}-utf8-ru.patch || die "utf8-ru patch failed"
+ epatch "${WORKDIR}/${P}-utf8-ru.patch" || die "utf8-ru patch failed"
fi
# use CFLAGS, CXXFLAGS, LDFLAGS
@@ -40,7 +40,7 @@ src_unpack() {
# Consolidate patches, apply FreeBSD configure patch, codepage patch,
# qtools stuff, and patches for bugs 129142, 121770, and 129560.
- epatch ${FILESDIR}/${PN}-1.5-legacy-patches.diff
+ epatch "${FILESDIR}/${PN}-1.5-legacy-patches.diff"
if is-flagq "-O3" ; then
echo
@@ -96,7 +96,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
dodoc INSTALL LANGUAGE.HOWTO README
diff --git a/app-doc/doxygen/doxygen-1.5.2.ebuild b/app-doc/doxygen/doxygen-1.5.2.ebuild
index 4f349aff8631..7dc1c0603771 100644
--- a/app-doc/doxygen/doxygen-1.5.2.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.2.ebuild,v 1.9 2007/07/23 02:41:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.2.ebuild,v 1.10 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils flag-o-matic toolchain-funcs qt3
@@ -24,7 +24,7 @@ EPATCH_SUFFIX="patch"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# use CFLAGS, CXXFLAGS, LDFLAGS
sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
@@ -34,7 +34,7 @@ src_unpack() {
# Consolidate patches, apply FreeBSD configure patch, codepage patch,
# qtools stuff, and patches for bugs 129142, 121770, and 129560.
- epatch ${FILESDIR}/${PN}-1.5-legacy-patches.diff
+ epatch "${FILESDIR}/${PN}-1.5-legacy-patches.diff"
if is-flagq "-O3" ; then
echo
@@ -91,7 +91,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
dodoc INSTALL LANGUAGE.HOWTO README
diff --git a/app-doc/doxygen/doxygen-1.5.3.ebuild b/app-doc/doxygen/doxygen-1.5.3.ebuild
index 175f95aaba4c..0d0560569f6e 100644
--- a/app-doc/doxygen/doxygen-1.5.3.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.3.ebuild,v 1.3 2007/11/03 16:39:24 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.3.ebuild,v 1.4 2007/11/21 06:17:24 nerdboy Exp $
inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
@@ -24,7 +24,7 @@ EPATCH_SUFFIX="patch"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# use CFLAGS, CXXFLAGS, LDFLAGS
sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
@@ -42,7 +42,7 @@ src_unpack() {
# Consolidate patches, apply FreeBSD configure patch, codepage patch,
# qtools stuff, and patches for bugs 129142, 121770, and 129560.
- epatch ${FILESDIR}/${PN}-1.5-legacy-patches.diff
+ epatch "${FILESDIR}/${PN}-1.5-legacy-patches.diff"
if is-flagq "-O3" ; then
echo
@@ -110,11 +110,11 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
if use qt3; then
- doicon ${FILESDIR}/doxywizard.png
+ doicon "${FILESDIR}/doxywizard.png"
make_desktop_entry doxywizard "DoxyWizard ${PV}" \
"doxywizard.png" "Application;Development"
fi
diff --git a/app-doc/doxygen/doxygen-1.5.4.ebuild b/app-doc/doxygen/doxygen-1.5.4.ebuild
new file mode 100644
index 000000000000..96b10aa9b7c8
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.5.4.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.4.ebuild,v 1.1 2007/11/21 06:17:24 nerdboy Exp $
+
+inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
+
+DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
+HOMEPAGE="http://www.doxygen.org/"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc nodot qt3 tetex elibc_FreeBSD"
+
+RDEPEND="qt3? ( $(qt_min_version 3.3) )
+ tetex? ( virtual/tetex )
+ virtual/ghostscript
+ !nodot? ( >=media-gfx/graphviz-2.6 )"
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+EPATCH_SUFFIX="patch"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # use CFLAGS, CXXFLAGS, LDFLAGS
+ sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf \
+ || die "sed failed"
+
+ # Consolidate patches, apply FreeBSD configure patch, codepage patch,
+ # qtools stuff, and patches for bugs 129142, 121770, and 129560.
+ epatch "${FILESDIR}/${PN}-1.5-legacy-patches.diff"
+
+ if is-flagq "-O3" ; then
+ echo
+ ewarn "Compiling with -O3 is known to produce incorrectly"
+ ewarn "optimized code which breaks doxygen."
+ echo
+ epause 6
+ elog "Continuing with -O2 instead ..."
+ echo
+ replace-flags "-O3" "-O2"
+ fi
+}
+
+src_compile() {
+ export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
+ # set ./configure options (prefix, Qt based wizard, docdir)
+
+ if use debug; then
+ local my_conf="--prefix ${D}usr --debug"
+ else
+ local my_conf="--prefix ${D}usr"
+ fi
+
+ if use qt3; then
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt3 doxywizard) \
+ || die 'configure with qt3 failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
+ fi
+
+ # and compile
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
+ LINK_SHLIB="$(tc-getCXX)" all || die 'emake failed'
+
+ # generate html and pdf (if tetex in use) documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ if use nodot; then
+ sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
+ {Doxyfile,doc/Doxyfile} || ewarn "disabling dot failed"
+ fi
+ if use tetex; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make pdf docs" failed.'
+ else
+ cp doc/Doxyfile doc/Doxyfile.orig
+ cp doc/Makefile doc/Makefile.orig
+ sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" \
+ doc/Doxyfile
+ sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
+ -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
+ -e "s/@sed/# @sed/" doc/Makefile
+ make docs || ewarn '"make html docs" failed.'
+ fi
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" MAN1DIR=share/man/man1 \
+ install || die '"make install" failed.'
+
+ if use qt3; then
+ doicon "${FILESDIR}/doxywizard.png"
+ make_desktop_entry doxywizard "DoxyWizard ${PV}" \
+ "doxywizard.png" "Application;Development"
+ fi
+
+ dodoc INSTALL LANGUAGE.HOWTO README
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ if use tetex; then
+ doins latex/doxygen_manual.pdf
+ fi
+ dohtml -r html/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ elog
+ elog "The USE flags qt, doc, and tetex will enable doxywizard, or"
+ elog "the html and pdf documentation, respectively. For examples"
+ elog "and other goodies, see the source tarball. For some example"
+ elog "output, run doxygen on the doxygen source using the Doxyfile"
+ elog "provided in the top-level source dir."
+ elog
+ elog "Enabling the nodot USE flag will remove the GraphViz dependency,"
+ elog "along with Doxygen's ability to generate diagrams in the docs."
+ elog "See the Doxygen homepage for additional language support tools."
+ elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-doc/doxygen/files/digest-doxygen-1.5.4 b/app-doc/doxygen/files/digest-doxygen-1.5.4
new file mode 100644
index 000000000000..a83c890e0f4a
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.5.4
@@ -0,0 +1,3 @@
+MD5 10ffe8d445dc1bf7dd69292b266906ff doxygen-1.5.4.src.tar.gz 3762535
+RMD160 263e2287da4fbe91a429dc53fe3569b150c76fdf doxygen-1.5.4.src.tar.gz 3762535
+SHA256 12e6a2166b8c78a991d4ceef1dd9042117b24b76e20ccfdfdfc30bc4a7e31df2 doxygen-1.5.4.src.tar.gz 3762535