summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-08-14 23:54:51 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-08-14 23:54:51 +0000
commit8be0b37cd09e8f55f99befeace008d1f8d55a3f7 (patch)
tree83f18ba40dbd531b046f9143d7461e522966dfc1 /dev-db
parent Revision with libmtp patch... (diff)
downloadgentoo-2-8be0b37cd09e8f55f99befeace008d1f8d55a3f7.tar.gz
gentoo-2-8be0b37cd09e8f55f99befeace008d1f8d55a3f7.tar.bz2
gentoo-2-8be0b37cd09e8f55f99befeace008d1f8d55a3f7.zip
Fixed to work with >=postgresql-8.2, bug #234719.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgmecab/ChangeLog8
-rw-r--r--dev-db/pgmecab/files/pgmecab-1.1-gentoo.patch26
-rw-r--r--dev-db/pgmecab/pgmecab-1.1-r1.ebuild31
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-db/pgmecab/ChangeLog b/dev-db/pgmecab/ChangeLog
index c674c03b4a41..43b706e56226 100644
--- a/dev-db/pgmecab/ChangeLog
+++ b/dev-db/pgmecab/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgmecab
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/ChangeLog,v 1.2 2008/05/21 15:56:55 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/ChangeLog,v 1.3 2008/08/14 23:54:50 matsuu Exp $
+
+*pgmecab-1.1-r1 (14 Aug 2008)
+
+ 14 Aug 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/pgmecab-1.1-gentoo.patch, +pgmecab-1.1-r1.ebuild:
+ Fixed to work with >=postgresql-8.2, bug #234719.
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> pgmecab-1.1.ebuild:
Changed dependency for postgresql from dev-db/postgresql to
diff --git a/dev-db/pgmecab/files/pgmecab-1.1-gentoo.patch b/dev-db/pgmecab/files/pgmecab-1.1-gentoo.patch
new file mode 100644
index 000000000000..6422f62c1a7a
--- /dev/null
+++ b/dev-db/pgmecab/files/pgmecab-1.1-gentoo.patch
@@ -0,0 +1,26 @@
+diff -Naur pgmecab-1.1.orig/Makefile pgmecab-1.1/Makefile
+--- pgmecab-1.1.orig/Makefile 2006-02-15 00:37:12.000000000 +0900
++++ pgmecab-1.1/Makefile 2008-08-15 02:19:55.000000000 +0900
+@@ -4,7 +4,7 @@
+ #
+ #-------------------------------------------------------------------------
+ # MECAB_CONFIG_PATH = /usr/local/mecab/bin/mecab-config
+-MECAB_CONFIG_PATH =
++MECAB_CONFIG_PATH = /usr/bin/mecab-config
+
+ SRCS = pgmecab.c
+
+diff -Naur pgmecab-1.1.orig/pgmecab.c pgmecab-1.1/pgmecab.c
+--- pgmecab-1.1.orig/pgmecab.c 2006-02-15 00:36:39.000000000 +0900
++++ pgmecab-1.1/pgmecab.c 2008-08-15 02:19:07.000000000 +0900
+@@ -7,7 +7,9 @@
+
+ #include "postgres.h"
+ #include "fmgr.h"
+-
++#ifdef PG_MODULE_MAGIC
++PG_MODULE_MAGIC;
++#endif
+ #include "mecab.h"
+
+ #include <stdio.h>
diff --git a/dev-db/pgmecab/pgmecab-1.1-r1.ebuild b/dev-db/pgmecab/pgmecab-1.1-r1.ebuild
new file mode 100644
index 000000000000..1d7f215e5eca
--- /dev/null
+++ b/dev-db/pgmecab/pgmecab-1.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/pgmecab-1.1-r1.ebuild,v 1.1 2008/08/14 23:54:50 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="PostgreSQL function to Wakachigaki for Japanese words"
+HOMEPAGE="http://www.emaki.minidns.net/Programming/postgres/index.html"
+SRC_URI="http://www.emaki.minidns.net/Programming/postgres/${P}.tar.bz2"
+
+DEPEND="app-text/mecab
+ >=virtual/postgresql-server-7.4"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake USE_PGXS=1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install || die
+}