summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 20:54:43 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 20:54:43 +0000
commit5a2794215ff41b7c82a8d4a4551596952da5955c (patch)
tree0387e26f43780fde4fba4067c1823cfe19829bf4 /dev-lisp
parentadded "die" (diff)
downloadgentoo-2-5a2794215ff41b7c82a8d4a4551596952da5955c.tar.gz
gentoo-2-5a2794215ff41b7c82a8d4a4551596952da5955c.tar.bz2
gentoo-2-5a2794215ff41b7c82a8d4a4551596952da5955c.zip
add inherit eutils
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/clisp-2.32-r1.ebuild65
-rw-r--r--dev-lisp/clisp/clisp-2.32.ebuild65
-rw-r--r--dev-lisp/clisp/clisp-2.33.ebuild63
3 files changed, 92 insertions, 101 deletions
diff --git a/dev-lisp/clisp/clisp-2.32-r1.ebuild b/dev-lisp/clisp/clisp-2.32-r1.ebuild
index 2b8322506cd7..8feee179a91e 100644
--- a/dev-lisp/clisp/clisp-2.32-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.32-r1.ebuild
@@ -1,41 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32-r1.ebuild,v 1.4 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32-r1.ebuild,v 1.5 2004/04/25 20:53:13 vapier Exp $
-inherit flag-o-matic common-lisp-common
-
-IUSE="X threads fastcgi postgres ldap nls berkdb"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
+inherit flag-o-matic common-lisp-common eutils
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86"
+IUSE="X threads fastcgi postgres ldap nls berkdb"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -45,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
readline? ( sys-libs/readline )
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="x86"
src_unpack() {
unpack ${A}
@@ -56,6 +30,29 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS
diff --git a/dev-lisp/clisp/clisp-2.32.ebuild b/dev-lisp/clisp/clisp-2.32.ebuild
index b14df0bd3eec..7b303a1fbb48 100644
--- a/dev-lisp/clisp/clisp-2.32.ebuild
+++ b/dev-lisp/clisp/clisp-2.32.ebuild
@@ -1,41 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32.ebuild,v 1.2 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32.ebuild,v 1.3 2004/04/25 20:54:05 vapier Exp $
-inherit flag-o-matic
-
-IUSE="X threads fastcgi postgres ldap nls berkdb"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
+inherit flag-o-matic eutils
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86"
+IUSE="X threads fastcgi postgres ldap nls berkdb"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -45,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
readline? ( sys-libs/readline )
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~x86"
src_unpack() {
unpack ${A}
@@ -56,6 +30,29 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS
diff --git a/dev-lisp/clisp/clisp-2.33.ebuild b/dev-lisp/clisp/clisp-2.33.ebuild
index 0c1f01fe9e65..df037726d915 100644
--- a/dev-lisp/clisp/clisp-2.33.ebuild
+++ b/dev-lisp/clisp/clisp-2.33.ebuild
@@ -1,41 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.ebuild,v 1.3 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.ebuild,v 1.4 2004/04/25 20:54:43 vapier Exp $
inherit flag-o-matic common-lisp-common
-IUSE="X fastcgi postgres nls berkdb pcre"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
-
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86"
+IUSE="X fastcgi postgres nls berkdb pcre"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -45,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )
pcre? ( dev-libs/libpcre )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="x86"
src_unpack() {
unpack ${A}
@@ -56,6 +30,29 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS