summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-10 19:53:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-10 19:53:23 +0000
commita26a259df45a27b29e07da425254a93894520f96 (patch)
tree7015ac7e82b9ba6c04dd35a4ce0e35abfad32261 /dev-python
parentre-fixing vmtoolsd plugin path (diff)
downloadgentoo-2-a26a259df45a27b29e07da425254a93894520f96.tar.gz
gentoo-2-a26a259df45a27b29e07da425254a93894520f96.tar.bz2
gentoo-2-a26a259df45a27b29e07da425254a93894520f96.zip
Version bump.
(Portage version: 13812-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gdata/ChangeLog8
-rw-r--r--dev-python/gdata/gdata-2.0.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index b869d501c43b..d91573cda86c 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.21 2009/06/23 11:15:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.22 2009/07/10 19:53:23 arfrever Exp $
+
+*gdata-2.0.0 (10 Jul 2009)
+
+ 10 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +gdata-2.0.0.ebuild:
+ Version bump.
*gdata-1.3.3 (23 Jun 2009)
diff --git a/dev-python/gdata/gdata-2.0.0.ebuild b/dev-python/gdata/gdata-2.0.0.ebuild
new file mode 100644
index 000000000000..ffa9545703da
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.0.ebuild,v 1.1 2009/07/10 19:53:23 arfrever Exp $
+
+inherit distutils eutils
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
+
+PYTHON_MODNAME="atom gdata"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+src_test() {
+ cd tests
+ export PYTHONPATH=../src
+ "${python}" run_data_tests.py -v || die "Data tests failed"
+
+ # run_service_tests.py requires interaction (and a valid google account), so skip.
+ #"${python}" run_service_tests.py -v || die "Service tests failed"
+}