summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-03-27 02:33:32 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-03-27 02:33:32 +0000
commitf8c4425e8d1741f947eb8c1aa96d642fba5bc4f5 (patch)
tree10f22c75d611e6816e3f01b88c1096d46617d498 /dev-ruby/stringex
parentCleanup old. (diff)
downloadgentoo-2-f8c4425e8d1741f947eb8c1aa96d642fba5bc4f5.tar.gz
gentoo-2-f8c4425e8d1741f947eb8c1aa96d642fba5bc4f5.tar.bz2
gentoo-2-f8c4425e8d1741f947eb8c1aa96d642fba5bc4f5.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/stringex')
-rw-r--r--dev-ruby/stringex/ChangeLog9
-rw-r--r--dev-ruby/stringex/stringex-2.4.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-ruby/stringex/ChangeLog b/dev-ruby/stringex/ChangeLog
index ebf6fb1aebaa..d1a0feded1fe 100644
--- a/dev-ruby/stringex/ChangeLog
+++ b/dev-ruby/stringex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/stringex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stringex/ChangeLog,v 1.17 2013/10/25 09:05:58 graaff Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stringex/ChangeLog,v 1.18 2014/03/27 02:33:32 mrueg Exp $
+
+*stringex-2.4.2 (27 Mar 2014)
+
+ 27 Mar 2014; Manuel Rüger <mrueg@gentoo.org> +stringex-2.4.2.ebuild:
+ Version bump.
25 Oct 2013; Hans de Graaff <graaff@gentoo.org> stringex-2.0.8.ebuild:
Add ruby20, but skip the rails tests and dependencies for now so we can
diff --git a/dev-ruby/stringex/stringex-2.4.2.ebuild b/dev-ruby/stringex/stringex-2.4.2.ebuild
new file mode 100644
index 000000000000..1b43126a1ea1
--- /dev/null
+++ b/dev-ruby/stringex/stringex-2.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stringex/stringex-2.4.2.ebuild,v 1.1 2014/03/27 02:33:32 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_DOC_DIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extensions for Ruby's String class"
+HOMEPAGE="http://github.com/rsl/stringex"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# we could rely on activerecord[sqlite3], but since we do not remove the
+# sqlite3 adapter from activerecord when building -sqlite3, it's easier
+# to just add another dependency, so the user doesn't have to change the
+# USE flags at all.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord:3.2
+ dev-ruby/sqlite3
+ dev-ruby/redcloth
+ dev-ruby/test-unit:2
+ )"
+
+each_ruby_test() {
+ # rake seems to break this
+ ruby-ng_testrb-2 -Ilib -Itest test/{unit,performance}/**/*_test.rb || die "tests failed"
+}