summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 16:40:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 16:40:29 +0000
commit455519745f12edb30d77e6b82729c3620809a919 (patch)
tree9f7f8ab4b0e5f58cde6e599ae837fcaefe43ce2b /dev-ruby
parentAdd a patch to fix a big bug on JRuby. (diff)
downloadgentoo-2-455519745f12edb30d77e6b82729c3620809a919.tar.gz
gentoo-2-455519745f12edb30d77e6b82729c3620809a919.tar.bz2
gentoo-2-455519745f12edb30d77e6b82729c3620809a919.zip
Add patch to force support for mocha 0.9.5 or later, and adds support for JRuby.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/ChangeLog10
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild (renamed from dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild)8
-rw-r--r--dev-ruby/activesupport/files/activesupport-2.3.5-mocha-0.9.5.patch18
3 files changed, 33 insertions, 3 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 31d441da6d7f..0eaf8fbe377d 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.116 2010/01/18 19:04:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.117 2010/02/01 16:40:29 flameeyes Exp $
+
+*activesupport-2.3.5-r4 (01 Feb 2010)
+
+ 01 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -activesupport-2.3.5-r3.ebuild, +activesupport-2.3.5-r4.ebuild,
+ +files/activesupport-2.3.5-mocha-0.9.5.patch:
+ Add patch to force support for mocha 0.9.5 or later, and adds support for
+ JRuby.
*activesupport-2.3.5-r3 (18 Jan 2010)
diff --git a/dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild b/dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild
index a116a868e9ac..3a7bd8144cc9 100644
--- a/dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild
+++ b/dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5-r3.ebuild,v 1.1 2010/01/18 19:04:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild,v 1.1 2010/02/01 16:40:29 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_TASK_DOC=""
@@ -31,4 +31,8 @@ all_ruby_prepare() {
# well as fixing the dependencies for i18n to use only the 0.1
# slot.
epatch "${FILESDIR}"/${P}-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${P}-mocha-0.9.5.patch
}
diff --git a/dev-ruby/activesupport/files/activesupport-2.3.5-mocha-0.9.5.patch b/dev-ruby/activesupport/files/activesupport-2.3.5-mocha-0.9.5.patch
new file mode 100644
index 000000000000..4b6381e337fd
--- /dev/null
+++ b/dev-ruby/activesupport/files/activesupport-2.3.5-mocha-0.9.5.patch
@@ -0,0 +1,18 @@
+Index: activesupport-2.3.5/lib/active_support/testing/setup_and_teardown.rb
+===================================================================
+--- activesupport-2.3.5.orig/lib/active_support/testing/setup_and_teardown.rb
++++ activesupport-2.3.5/lib/active_support/testing/setup_and_teardown.rb
+@@ -45,12 +45,7 @@ module ActiveSupport
+ return if @method_name.to_s == "default_test"
+
+ if using_mocha = respond_to?(:mocha_verify)
+- assertion_counter_klass = if defined?(Mocha::TestCaseAdapter::AssertionCounter)
+- Mocha::TestCaseAdapter::AssertionCounter
+- else
+- Mocha::Integration::TestUnit::AssertionCounter
+- end
+- assertion_counter = assertion_counter_klass.new(result)
++ assertion_counter = Mocha::Integration::TestUnit::AssertionCounter.new(result)
+ end
+
+ yield(Test::Unit::TestCase::STARTED, name)