summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-05-28 17:55:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-05-28 17:55:35 +0000
commit651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21 (patch)
tree3d2e1223705783bb60d0a948072a0a4a41625265 /dev-util/git/files/20080528-git-1.5.5.3-noperl.patch
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21.tar.gz
gentoo-2-651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21.tar.bz2
gentoo-2-651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21.zip
Version bump, 1.5.5 series is pretty ready for primetime.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-util/git/files/20080528-git-1.5.5.3-noperl.patch')
-rw-r--r--dev-util/git/files/20080528-git-1.5.5.3-noperl.patch327
1 files changed, 327 insertions, 0 deletions
diff --git a/dev-util/git/files/20080528-git-1.5.5.3-noperl.patch b/dev-util/git/files/20080528-git-1.5.5.3-noperl.patch
new file mode 100644
index 000000000000..5fbdc4136a96
--- /dev/null
+++ b/dev-util/git/files/20080528-git-1.5.5.3-noperl.patch
@@ -0,0 +1,327 @@
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/builtin-add.c git-1.5.5.3/builtin-add.c
+--- git-1.5.5.3.orig/builtin-add.c 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/builtin-add.c 2008-05-28 10:38:12.566970120 -0700
+@@ -135,6 +135,7 @@
+ free(seen);
+ }
+
++#ifndef NO_PERL
+ static const char **validate_pathspec(int argc, const char **argv, const char *prefix)
+ {
+ const char **pathspec = get_pathspec(prefix, argv);
+@@ -170,6 +171,7 @@
+ free(args);
+ return status;
+ }
++#endif
+
+ static struct lock_file lock_file;
+
+@@ -182,8 +184,10 @@
+ OPT__DRY_RUN(&show_only),
+ OPT__VERBOSE(&verbose),
+ OPT_GROUP(""),
++#ifndef NO_PERL
+ OPT_BOOLEAN('i', "interactive", &add_interactive, "interactive picking"),
+ OPT_BOOLEAN('p', "patch", &patch_interactive, "interactive patching"),
++#endif
+ OPT_BOOLEAN('f', NULL, &ignored_too, "allow adding otherwise ignored files"),
+ OPT_BOOLEAN('u', NULL, &take_worktree_changes, "update tracked files"),
+ OPT_BOOLEAN( 0 , "refresh", &refresh_only, "don't add, only refresh the index"),
+@@ -198,10 +202,12 @@
+
+ argc = parse_options(argc, argv, builtin_add_options,
+ builtin_add_usage, 0);
++#ifndef NO_PERL
+ if (patch_interactive)
+ add_interactive = 1;
+ if (add_interactive)
+ exit(interactive_add(argc, argv, prefix));
++#endif
+
+ git_config(git_default_config);
+
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/builtin-commit.c git-1.5.5.3/builtin-commit.c
+--- git-1.5.5.3.orig/builtin-commit.c 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/builtin-commit.c 2008-05-28 10:38:25.556703720 -0700
+@@ -97,7 +97,9 @@
+ OPT_GROUP("Commit contents options"),
+ OPT_BOOLEAN('a', "all", &all, "commit all changed files"),
+ OPT_BOOLEAN('i', "include", &also, "add specified files to index for commit"),
++#ifndef NO_PERL
+ OPT_BOOLEAN(0, "interactive", &interactive, "interactively add files"),
++#endif
+ OPT_BOOLEAN('o', "only", &only, "commit only specified files"),
+ OPT_BOOLEAN('n', "no-verify", &no_verify, "bypass pre-commit hook"),
+ OPT_BOOLEAN(0, "amend", &amend, "amend previous commit"),
+@@ -217,6 +219,7 @@
+ struct path_list partial;
+ const char **pathspec = NULL;
+
++#ifndef NO_PERL
+ if (interactive) {
+ interactive_add(argc, argv, prefix);
+ if (read_cache() < 0)
+@@ -224,6 +227,7 @@
+ commit_style = COMMIT_AS_IS;
+ return get_index_file();
+ }
++#endif
+
+ if (read_cache() < 0)
+ die("index file corrupt");
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/Makefile git-1.5.5.3/Makefile
+--- git-1.5.5.3.orig/Makefile 2008-05-28 10:38:03.608016000 -0700
++++ git-1.5.5.3/Makefile 2008-05-28 10:38:12.571288044 -0700
+@@ -130,6 +130,8 @@
+ #
+ # Define NO_PERL_MAKEMAKER if you cannot use Makefiles generated by perl's
+ # MakeMaker (e.g. using ActiveState under Cygwin).
++
++# Define NO_PERL if you do not want Perl scripts at all.
+ #
+ # Define NO_TCLTK if you do not want Tcl/Tk GUI.
+ #
+@@ -255,6 +257,8 @@
+ SCRIPT_SH += git-submodule.sh
+ SCRIPT_SH += git-web--browse.sh
+
++SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH))
++ifndef NO_PERL
+ SCRIPT_PERL += git-add--interactive.perl
+ SCRIPT_PERL += git-archimport.perl
+ SCRIPT_PERL += git-cvsexportcommit.perl
+@@ -263,10 +267,11 @@
+ SCRIPT_PERL += git-relink.perl
+ SCRIPT_PERL += git-send-email.perl
+ SCRIPT_PERL += git-svn.perl
+-
+-SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH)) \
+- $(patsubst %.perl,%,$(SCRIPT_PERL)) \
+- git-instaweb
++SCRIPTS += $(patsubst %.perl,%,$(SCRIPT_PERL)) \
++ git-instaweb
++else
++SCRIPT_PERL =
++endif
+
+ # Empty...
+ EXTRA_PROGRAMS =
+@@ -315,7 +320,10 @@
+ ALL_PROGRAMS = $(PROGRAMS) $(SCRIPTS)
+
+ # what 'all' will build but not install in gitexecdir
+-OTHER_PROGRAMS = git$X gitweb/gitweb.cgi
++OTHER_PROGRAMS = git$X
++ifndef NO_PERL
++OTHER_PROGRAMS += gitweb/gitweb.cgi
++endif
+
+ # Set paths to tools early so that they can be used for version tests.
+ ifndef SHELL_PATH
+@@ -716,6 +724,10 @@
+ endif
+ endif
+
++ifdef NO_PERL
++ BASIC_CFLAGS += -DNO_PERL
++endif
++
+ ifdef ZLIB_PATH
+ BASIC_CFLAGS += -I$(ZLIB_PATH)/include
+ EXTLIBS += -L$(ZLIB_PATH)/$(lib) $(CC_LD_DYNPATH)$(ZLIB_PATH)/$(lib)
+@@ -896,6 +908,11 @@
+ ifeq ($(TCLTK_PATH),)
+ NO_TCLTK=NoThanks
+ endif
++ifeq ($(PERL_PATH),)
++NO_PERL=NoThanks
++export NO_PERL
++export NO_PERL_MAKEMAKER
++endif
+
+ QUIET_SUBDIR0 = +$(MAKE) -C # space to separate -C and subdir
+ QUIET_SUBDIR1 =
+@@ -968,7 +985,9 @@
+ $(QUIET_SUBDIR0)git-gui $(QUIET_SUBDIR1) all
+ $(QUIET_SUBDIR0)gitk-git $(QUIET_SUBDIR1) all
+ endif
++ifndef NO_PERL
+ $(QUIET_SUBDIR0)perl $(QUIET_SUBDIR1) PERL_PATH='$(PERL_PATH_SQ)' prefix='$(prefix_SQ)' all
++endif
+ $(QUIET_SUBDIR0)templates $(QUIET_SUBDIR1)
+
+ strip: $(PROGRAMS) git$X
+@@ -1007,6 +1026,7 @@
+ chmod +x $@+ && \
+ mv $@+ $@
+
++ifndef NO_PERL
+ $(patsubst %.perl,%,$(SCRIPT_PERL)): perl/perl.mak
+
+ perl/perl.mak: GIT-CFLAGS perl/Makefile perl/Makefile.PL
+@@ -1065,6 +1085,7 @@
+ $@.sh > $@+ && \
+ chmod +x $@+ && \
+ mv $@+ $@
++endif # NO_PERL
+
+ configure: configure.ac
+ $(QUIET_GEN)$(RM) $@ $<+ && \
+@@ -1218,7 +1239,9 @@
+ $(INSTALL) $(ALL_PROGRAMS) '$(DESTDIR_SQ)$(gitexecdir_SQ)'
+ $(INSTALL) git$X '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(MAKE) -C templates DESTDIR='$(DESTDIR_SQ)' install
++ifndef NO_PERL
+ $(MAKE) -C perl prefix='$(prefix_SQ)' DESTDIR='$(DESTDIR_SQ)' install
++endif
+ ifndef NO_TCLTK
+ $(MAKE) -C gitk-git install
+ $(MAKE) -C git-gui install
+@@ -1307,9 +1330,11 @@
+ $(RM) -r $(GIT_TARNAME) .doc-tmp-dir
+ $(RM) $(GIT_TARNAME).tar.gz git-core_$(GIT_VERSION)-*.tar.gz
+ $(RM) $(htmldocs).tar.gz $(manpages).tar.gz
+- $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C Documentation/ clean
++ifndef NO_PERL
++ $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C perl clean
++endif
+ $(MAKE) -C templates/ clean
+ $(MAKE) -C t/ clean
+ ifndef NO_TCLTK
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/lib-git-svn.sh git-1.5.5.3/t/lib-git-svn.sh
+--- git-1.5.5.3.orig/t/lib-git-svn.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/lib-git-svn.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -6,6 +6,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-svn tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ GIT_DIR=$PWD/.git
+ GIT_SVN_DIR=$GIT_DIR/svn/git-svn
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t5505-remote.sh git-1.5.5.3/t/t5505-remote.sh
+--- git-1.5.5.3.orig/t/t5505-remote.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t5505-remote.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -3,6 +3,12 @@
+ test_description='git remote porcelain-ish'
+
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsimport tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ setup_repository () {
+ mkdir "$1" && (
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t7501-commit.sh git-1.5.5.3/t/t7501-commit.sh
+--- git-1.5.5.3.orig/t/t7501-commit.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t7501-commit.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -38,7 +38,7 @@
+ "echo King of the bongo >file &&
+ ! git-commit -m foo -a file"
+
+-test_expect_success \
++[ -z "$NO_PERL" ] && test_expect_success \
+ "using paths with --interactive" \
+ "echo bong-o-bong >file &&
+ ! echo 7 | git-commit -m foo --interactive file"
+@@ -119,7 +119,7 @@
+ "echo 'gak' >file && \
+ git-commit -m 'author' --author 'Rubber Duck <rduck@convoy.org>' -a"
+
+-test_expect_success \
++[ -z "$NO_PERL" ] && test_expect_success \
+ "interactive add" \
+ "echo 7 | git-commit --interactive | grep 'What now'"
+
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9001-send-email.sh git-1.5.5.3/t/t9001-send-email.sh
+--- git-1.5.5.3.orig/t/t9001-send-email.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9001-send-email.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -2,6 +2,12 @@
+
+ test_description='git-send-email'
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-send-email tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ PROG='git send-email'
+ test_expect_success \
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9200-git-cvsexportcommit.sh git-1.5.5.3/t/t9200-git-cvsexportcommit.sh
+--- git-1.5.5.3.orig/t/t9200-git-cvsexportcommit.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9200-git-cvsexportcommit.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -13,6 +13,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsexportcommit tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ CVSROOT=$(pwd)/cvsroot
+ CVSWORK=$(pwd)/cvswork
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9400-git-cvsserver-server.sh git-1.5.5.3/t/t9400-git-cvsserver-server.sh
+--- git-1.5.5.3.orig/t/t9400-git-cvsserver-server.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9400-git-cvsserver-server.sh 2008-05-28 10:38:12.573745493 -0700
+@@ -17,6 +17,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsserver tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+ perl -e 'use DBI; use DBD::SQLite' >/dev/null 2>&1 || {
+ test_expect_success 'skipping git-cvsserver tests, Perl SQLite interface unavailable' :
+ test_done
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9500-gitweb-standalone-no-errors.sh git-1.5.5.3/t/t9500-gitweb-standalone-no-errors.sh
+--- git-1.5.5.3.orig/t/t9500-gitweb-standalone-no-errors.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9500-gitweb-standalone-no-errors.sh 2008-05-28 10:38:12.573745493 -0700
+@@ -67,6 +67,13 @@
+ }
+
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping gitweb-standalone-no-errors tests, NO_PERL defined' :
++ test_done
++ exit
++fi
++
+
+ perl -MEncode -e 'decode_utf8("", Encode::FB_CROAK)' >/dev/null 2>&1 || {
+ test_expect_success 'skipping gitweb tests, perl version is too old' :
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9600-cvsimport.sh git-1.5.5.3/t/t9600-cvsimport.sh
+--- git-1.5.5.3.orig/t/t9600-cvsimport.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9600-cvsimport.sh 2008-05-28 10:38:12.573745493 -0700
+@@ -15,6 +15,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsimport tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ cvsps_version=`cvsps -h 2>&1 | sed -ne 's/cvsps version //p'`
+ case "$cvsps_version" in