summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-29 06:24:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-29 06:24:03 +0000
commit122b014491d656b8f1715ff8d32b4c73746afa88 (patch)
tree0194561e539d914840a9d9e2afe7ed61eec445cb /games-arcade/ceferino/ceferino-0.96.ebuild
parentfix lib path for smsd database modules (#104050) (diff)
downloadgentoo-2-122b014491d656b8f1715ff8d32b4c73746afa88.tar.gz
gentoo-2-122b014491d656b8f1715ff8d32b4c73746afa88.tar.bz2
gentoo-2-122b014491d656b8f1715ff8d32b4c73746afa88.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-arcade/ceferino/ceferino-0.96.ebuild')
-rw-r--r--games-arcade/ceferino/ceferino-0.96.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-arcade/ceferino/ceferino-0.96.ebuild b/games-arcade/ceferino/ceferino-0.96.ebuild
new file mode 100644
index 000000000000..a0c390101d28
--- /dev/null
+++ b/games-arcade/ceferino/ceferino-0.96.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ceferino/ceferino-0.96.ebuild,v 1.1 2005/08/29 06:24:03 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Super-Pang clone (destroy bouncing balloons with your grapnel)"
+HOMEPAGE="http://www.loosersjuegos.com.ar/juegos/ceferino/ceferino.php"
+SRC_URI="http://www.loosersjuegos.com.ar/juegos/ceferino/descargas/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="nls"
+
+RDEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^install-data-am/s:install-docDATA::' Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e '/^\(gnu\)\?localedir /s:= .*:= /usr/share/locale:' \
+ po/Makefile.in.in src/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README README_ES TODO
+ newicon src/ima/icono.png ${PN}.png
+ make_desktop_entry ceferino "Don Ceferino Hazaña"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ ewarn
+ ewarn "To hear music, you will have to rebuild media-libs/sdl-mixer"
+ ewarn "with the \"mikmod\" USE flag turned on."
+ ewarn
+ fi
+}