summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-03-06 23:05:28 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-03-06 23:05:28 +0000
commitcaa45ddf335c3663cad7d18210dcb1985c72cdc8 (patch)
tree2d35ed967349f7c8f7e159230791d22c5513959d /sci-biology
parentVersion bump #305405 by Walther which also fixes #299962 by Dennis Schridde. (diff)
downloadgentoo-2-caa45ddf335c3663cad7d18210dcb1985c72cdc8.tar.gz
gentoo-2-caa45ddf335c3663cad7d18210dcb1985c72cdc8.tar.bz2
gentoo-2-caa45ddf335c3663cad7d18210dcb1985c72cdc8.zip
Version bump (bugfix release)
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mira/ChangeLog7
-rw-r--r--sci-biology/mira/mira-3.0.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sci-biology/mira/ChangeLog b/sci-biology/mira/ChangeLog
index e3d10b3a5912..a97612370582 100644
--- a/sci-biology/mira/ChangeLog
+++ b/sci-biology/mira/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/mira
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.4 2010/02/25 19:00:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.5 2010/03/06 23:05:28 weaver Exp $
+
+*mira-3.0.1 (06 Mar 2010)
+
+ 06 Mar 2010; Andrey Kislyuk <weaver@gentoo.org> +mira-3.0.1.ebuild:
+ Version bump (bugfix release)
25 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> mira-3.0.0.ebuild,
+files/mira-3.0.0-asneeded.patch:
diff --git a/sci-biology/mira/mira-3.0.1.ebuild b/sci-biology/mira/mira-3.0.1.ebuild
new file mode 100644
index 000000000000..ab4263fb42c9
--- /dev/null
+++ b/sci-biology/mira/mira-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.1.ebuild,v 1.1 2010/03/06 23:05:28 weaver Exp $
+
+EAPI="2"
+
+MIRA_3RDPARTY_PV="06-03-2010"
+
+inherit base autotools
+
+DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
+HOMEPAGE="http://www.chevreux.org/projects_mira.html"
+SRC_URI="mirror://sourceforge/mira-assembler/${P}.tar.bz2
+ mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND=">=dev-libs/boost-1.35.0"
+DEPEND="${CDEPEND}
+ dev-libs/expat
+ doc? ( >=app-text/texlive-core-2009 )"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
+ epatch "${FILESDIR}"/${PN}-3.0.0-asneeded.patch
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_compile() {
+ base_src_compile
+ if use doc; then emake -C doc clean docs || die; fi
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS GETTING_STARTED NEWS README* HELP_WANTED THANKS INSTALL
+ find doc/docs/man -type f | xargs doman
+ find doc/docs/texinfo -type f | xargs doinfo
+ dobin "${WORKDIR}"/3rdparty/{sff_extract,*.pl}
+}