summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-09 06:48:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-09 06:48:36 +0000
commit777d08fb89d6707e671fe96ad192e349a03a907d (patch)
treeafcb8bc8543bee29470f3dba2409cf268e8d058c /sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild
parentremoved old version which having problems with PYTHON ABIs stuff (diff)
downloadgentoo-2-777d08fb89d6707e671fe96ad192e349a03a907d.tar.gz
gentoo-2-777d08fb89d6707e671fe96ad192e349a03a907d.tar.bz2
gentoo-2-777d08fb89d6707e671fe96ad192e349a03a907d.zip
Version Bump, fixes for python.eclass usage
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild')
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild
deleted file mode 100644
index 3df525ec13ba..000000000000
--- a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild,v 1.1 2010/02/01 21:40:04 jlec Exp $
-
-EAPI="2"
-
-inherit python
-
-MY_PV="${PV##*_p}"
-
-DESCRIPTION="APBS plugin for pymol"
-HOMEPAGE="http://sourceforge.net/projects/pymolapbsplugin/"
-SRC_URI="http://pymolapbsplugin.svn.sourceforge.net/viewvc/pymolapbsplugin/trunk/src/apbsplugin.py?revision=${MY_PV} -> ${P}.py"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="pymol"
-IUSE=""
-
-RDEPEND="
- sci-chemistry/apbs
- sci-chemistry/pdb2pqr
- !<sci-chemistry/pymol-1.2.2-r1"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- cp "${DISTDIR}"/${P}.py "${WORKDIR}"/
-}
-
-src_install() {
- sed \
- -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
- -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/src/\":g" \
- -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/\":g" \
- -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
- -i ${P}.py
-
- insinto $(python_get_sitedir)/pmg_tk/startup/
- newins ${P}.py apbs_tools.py || die
-}
-
-pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
-}