summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-09-19 08:42:17 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-09-19 08:42:17 +0000
commit5a17993050f3c473fc0aa34e2fdf59d219d2eb59 (patch)
treec885d5069443f8ec969e91dd446f60622cff2381 /sys-fs/ddrescue
parentsci-chemistry/coot: Version Bump (diff)
downloadgentoo-2-5a17993050f3c473fc0aa34e2fdf59d219d2eb59.tar.gz
gentoo-2-5a17993050f3c473fc0aa34e2fdf59d219d2eb59.tar.bz2
gentoo-2-5a17993050f3c473fc0aa34e2fdf59d219d2eb59.zip
Version bump. Removed old
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-fs/ddrescue')
-rw-r--r--sys-fs/ddrescue/ChangeLog10
-rw-r--r--sys-fs/ddrescue/ddrescue-1.15.ebuild40
-rw-r--r--sys-fs/ddrescue/ddrescue-1.17.ebuild (renamed from sys-fs/ddrescue/ddrescue-1.15-r1.ebuild)19
3 files changed, 20 insertions, 49 deletions
diff --git a/sys-fs/ddrescue/ChangeLog b/sys-fs/ddrescue/ChangeLog
index 7ffa49c6ab23..e5cd2f7c35dd 100644
--- a/sys-fs/ddrescue/ChangeLog
+++ b/sys-fs/ddrescue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ddrescue
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.41 2012/08/15 11:07:43 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.42 2013/09/19 08:42:17 polynomial-c Exp $
+
+*ddrescue-1.17 (19 Sep 2013)
+
+ 19 Sep 2013; Lars Wendler <polynomial-c@gentoo.org> -ddrescue-1.15.ebuild,
+ -ddrescue-1.15-r1.ebuild, +ddrescue-1.17.ebuild:
+ Version bump. Removed old.
15 Aug 2012; Anthony G. Basile <blueness@gentoo.org> ddrescue-1.16.ebuild:
Stable ppc, bug #429214
diff --git a/sys-fs/ddrescue/ddrescue-1.15.ebuild b/sys-fs/ddrescue/ddrescue-1.15.ebuild
deleted file mode 100644
index 9471374b6773..000000000000
--- a/sys-fs/ddrescue/ddrescue-1.15.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.15.ebuild,v 1.4 2012/05/03 09:38:49 xmw Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="Copies data from one file or block device to another with read-error recovery"
-HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_compile() {
- # not a normal configure script
- ./configure \
- --prefix=/usr \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS}" \
- CXXFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_test() {
- ./testsuite/check.sh "${S}"/testsuite || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-man || die "make install failed"
- dodoc ChangeLog README NEWS AUTHORS
-}
diff --git a/sys-fs/ddrescue/ddrescue-1.15-r1.ebuild b/sys-fs/ddrescue/ddrescue-1.17.ebuild
index 509522e65768..d42f57f3ece5 100644
--- a/sys-fs/ddrescue/ddrescue-1.15-r1.ebuild
+++ b/sys-fs/ddrescue/ddrescue-1.17.ebuild
@@ -1,27 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.15-r1.ebuild,v 1.1 2012/05/03 12:20:24 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.17.ebuild,v 1.1 2013/09/19 08:42:17 polynomial-c Exp $
-EAPI=4
+EAPI=5
inherit toolchain-funcs
DESCRIPTION="Copies data from one file or block device to another with read-error recovery"
HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux"
IUSE=""
-DEPEND=""
+DEPEND="app-arch/lzip"
RDEPEND=""
+src_unpack() {
+ # Upstream only provides an lzip compressed tarball for this version
+ tar --lzip -xf "${DISTDIR}"/${P}.tar.lz || die
+}
+
src_configure() {
# not a normal configure script
econf \
- --prefix="${EPREFIX}"//usr \
+ --prefix="${EPREFIX}"/usr \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
CPPFLAGS="${CPPFLAGS}" \