summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-08-02 07:39:54 +0000
committerHans de Graaff <graaff@gentoo.org>2015-08-02 07:39:54 +0000
commit549bfd920959cfb8d40295cca91f5ff9eb1ec71e (patch)
treec0c628b734f2a7b3317cd66fa3f9b0a93ba46509 /virtual
parentVersion bump. (diff)
downloadgentoo-2-549bfd920959cfb8d40295cca91f5ff9eb1ec71e.tar.gz
gentoo-2-549bfd920959cfb8d40295cca91f5ff9eb1ec71e.tar.bz2
gentoo-2-549bfd920959cfb8d40295cca91f5ff9eb1ec71e.zip
Add virtual/ruby as a mechanism to record the need for a ruby interpreter in world, bug 556414.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/ruby/ChangeLog11
-rw-r--r--virtual/ruby/metadata.xml5
-rw-r--r--virtual/ruby/ruby-1.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/virtual/ruby/ChangeLog b/virtual/ruby/ChangeLog
new file mode 100644
index 000000000000..f2700ab8edf3
--- /dev/null
+++ b/virtual/ruby/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for virtual/ruby
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby/ChangeLog,v 1.1 2015/08/02 07:39:54 graaff Exp $
+
+*ruby-1 (02 Aug 2015)
+
+ 02 Aug 2015; Hans de Graaff <graaff@gentoo.org> +ruby-1.ebuild,
+ +metadata.xml:
+ Add virtual/ruby as a mechanism to record the need for a ruby interpreter in
+ world, bug 556414.
+
diff --git a/virtual/ruby/metadata.xml b/virtual/ruby/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/virtual/ruby/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/virtual/ruby/ruby-1.ebuild b/virtual/ruby/ruby-1.ebuild
new file mode 100644
index 000000000000..5dd1b534df19
--- /dev/null
+++ b/virtual/ruby/ruby-1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby/ruby-1.ebuild,v 1.1 2015/08/02 07:39:54 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22 rbx"
+
+inherit ruby-single
+
+DESCRIPTION="Virtual ebuild for ruby"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Ruby"
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RUBY_DEPS}"
+
+# The purpose of this ebuild is to provide a mechanism for end-users to
+# install the "best" ruby version on their system, based on current
+# stable versions and default RUBY_TARGETS. Other ebuilds should not
+# depend on this but instead use the ruby-single eclass.