summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/step/ChangeLog6
-rw-r--r--kde-base/step/files/step-4.3.2-solaris.patch69
-rw-r--r--kde-base/step/step-4.3.4.ebuild11
3 files changed, 82 insertions, 4 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 367a8eacc393..ed1bd4d36ef3 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/step
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.38 2009/12/11 00:01:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.39 2009/12/23 01:45:16 abcd Exp $
+
+ 23 Dec 2009; Jonathan Callen <abcd@gentoo.org>
+ +files/step-4.3.2-solaris.patch, step-4.3.4.ebuild:
+ Pull in changes from overlay; add patch for prefix support (Solaris)
11 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> -step-4.3.1.ebuild:
Drop KDE SC-4.3.1.
diff --git a/kde-base/step/files/step-4.3.2-solaris.patch b/kde-base/step/files/step-4.3.2-solaris.patch
new file mode 100644
index 000000000000..000f36228f74
--- /dev/null
+++ b/kde-base/step/files/step-4.3.2-solaris.patch
@@ -0,0 +1,69 @@
+Desc: Fix compilation on Solaris.
+Author: Heiko Przybyl <zuxez@cs.tu-berlin.de>
+--- step-4.3.2/step/stepcore/constraintsolver.cc.orig 2009-10-16 18:42:52.562521176 +0200
++++ step-4.3.2/step/stepcore/constraintsolver.cc 2009-10-16 18:44:15.447949305 +0200
+@@ -21,4 +21,18 @@
+ #include <unsupported/Eigen/IterativeSolvers>
+ #include <cmath>
++
++// Stolen from kcalc.
++#if defined(Q_OS_SOLARIS)
++// Strictly by the standard, ininf() is a c99-ism which
++// is unavailable in C++. The IEEE FP headers provide
++// a function with similar functionality, so use that instead.
++// However, !finite(a) == isinf(a) || isnan(a), so it's
++// not 100% correct.
++#include <ieeefp.h>
++namespace std {
++ inline int isinf(double a) { return !finite(a); }
++ inline int isfinite(double a) { return finite(a); }
++}
++#endif
+
+ using namespace Eigen;
+--- step-4.3.2/step/stepcore/particle.cc.orig 2009-10-16 19:23:50.845435007 +0200
++++ step-4.3.2/step/stepcore/particle.cc 2009-10-16 19:24:33.425319075 +0200
+@@ -22,6 +22,20 @@
+ #include <cmath>
+ #include <QtGlobal>
+
++// Stolen from kcalc.
++#if defined(Q_OS_SOLARIS)
++// Strictly by the standard, ininf() is a c99-ism which
++// is unavailable in C++. The IEEE FP headers provide
++// a function with similar functionality, so use that instead.
++// However, !finite(a) == isinf(a) || isnan(a), so it's
++// not 100% correct.
++#include <ieeefp.h>
++namespace std {
++ inline int isinf(double a) { return !finite(a); }
++ inline int isfinite(double a) { return finite(a); }
++}
++#endif
++
+ namespace StepCore
+ {
+
+--- step-4.3.2/step/stepcore/rigidbody.cc.orig 2009-10-16 19:24:57.664177635 +0200
++++ step-4.3.2/step/stepcore/rigidbody.cc 2009-10-16 19:25:08.616915717 +0200
+@@ -21,6 +21,20 @@
+ #include <cstring>
+ #include <cmath>
+
++// Stolen from kcalc.
++#if defined(Q_OS_SOLARIS)
++// Strictly by the standard, ininf() is a c99-ism which
++// is unavailable in C++. The IEEE FP headers provide
++// a function with similar functionality, so use that instead.
++// However, !finite(a) == isinf(a) || isnan(a), so it's
++// not 100% correct.
++#include <ieeefp.h>
++namespace std {
++ inline int isinf(double a) { return !finite(a); }
++ inline int isfinite(double a) { return finite(a); }
++}
++#endif
++
+ namespace StepCore
+ {
+
diff --git a/kde-base/step/step-4.3.4.ebuild b/kde-base/step/step-4.3.4.ebuild
index b83999985b62..8124672aded8 100644
--- a/kde-base/step/step-4.3.4.ebuild
+++ b/kde-base/step/step-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.3.4.ebuild,v 1.1 2009/12/01 11:34:10 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.3.4.ebuild,v 1.2 2009/12/23 01:45:16 abcd Exp $
EAPI="2"
@@ -20,10 +20,15 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
src_configure() {
- mycmakeargs="${mycmakeargs}
+ mycmakeargs=(
$(cmake-utils_use_with gsl)
- $(cmake-utils_use_with qalculate)"
+ $(cmake-utils_use_with qalculate)
+ )
kde4-meta_src_configure
}