summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog1
-rw-r--r--app-text/ttf2pt1/files/digest-ttf2pt1-3.3.01
-rw-r--r--app-text/ttf2pt1/ttf2pt1-3.3.0.ebuild36
-rw-r--r--current-packages1
-rw-r--r--package-buildorder2
-rw-r--r--skel.ebuild28
6 files changed, 69 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 423a6bbf80b4..3831912a4004 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,6 @@
09.10.2000
+ - New app-text/ttf2pt1 3.3.0 (achim)
- New media-gfx/blender 2.04 (achim)
- New media-libs/mesa-glu 3.2.1 (achim)
- new media-libs/glut 3.7 (achim)
diff --git a/app-text/ttf2pt1/files/digest-ttf2pt1-3.3.0 b/app-text/ttf2pt1/files/digest-ttf2pt1-3.3.0
new file mode 100644
index 000000000000..8266ad48f3f8
--- /dev/null
+++ b/app-text/ttf2pt1/files/digest-ttf2pt1-3.3.0
@@ -0,0 +1 @@
+MD5 ae685fc836bee971b168e6f92c7ce3c2 ttf2pt1-3.3.0.tgz
diff --git a/app-text/ttf2pt1/ttf2pt1-3.3.0.ebuild b/app-text/ttf2pt1/ttf2pt1-3.3.0.ebuild
new file mode 100644
index 000000000000..e6c1d3b44d9e
--- /dev/null
+++ b/app-text/ttf2pt1/ttf2pt1-3.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.3.0.ebuild,v 1.1 2000/10/09 18:00:52 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="Converts True Type to Type 1 fonts"
+SRC_URI="http://download.sourceforge.net/ttf2pt1/${A}"
+HOMEPAGE="http://ttf2pt1.sourceforge.net"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+
+}
+
+src_compile() {
+
+ cd ${S}
+ try make all
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin t1asm ttf2pfa ttf2pt1
+ dodoc CHANGES COPYRIGHT README
+
+}
+
diff --git a/current-packages b/current-packages
index 86c456bf579d..0da37daa1077 100644
--- a/current-packages
+++ b/current-packages
@@ -116,6 +116,7 @@
./app-text/openjade/openjade-1.3-r1.ebuild
./app-text/sablotron/sablotron-0.44.ebuild
./app-text/sgml2x/sgml2x-0.11-r1.ebuild
+./app-text/ttf2pt1/ttf2pt1-3.3.0.ebuildk
./app-text/rcs/rcs-5.7.ebuild
./app-text/tetex/tetex-1.0.7-r1.ebuild
./dev-db/mysql/mysql-3.23.24.ebuild
diff --git a/package-buildorder b/package-buildorder
index dbdb40b1e796..628ed0b25b6f 100644
--- a/package-buildorder
+++ b/package-buildorder
@@ -68,6 +68,7 @@ X ./media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild
./app-text/openjade/openjade-1.3-r1.ebuild
./app-text/sgml2x/sgml2x-0.11-r1.ebuild
./app-text/tetex/tetex-1.0.7-r1.ebuild
+./app-text/ttf2pt1/ttf2pt1-3.3.0.ebuild
./app-text/rcs/rcs-5.7.ebuild
./app-text/ghostscript/ghostscript-6.23.ebuild
./dev-lang/nasm/nasm-0.98-r1.ebuild
@@ -104,6 +105,7 @@ X ./media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild
./dev-java/jndi/jndi-1.2.1-r1.ebuild
./dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild
./dev-java/xt/xt-1.ebuild
+./media-gfb/blender/blender-2.04.ebuild
./media-gfx/gimp/gimp-1.1.26.ebuild
./media-gfx/gimp-print/gimp-print-4.0_beta2.ebuild
./media-gfx/imagemagic/imagemagic-5.2.4.ebuild
diff --git a/skel.ebuild b/skel.ebuild
new file mode 100644
index 000000000000..537cf0f429da
--- /dev/null
+++ b/skel.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header$
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION=""
+SRC_URI="ftp://"
+HOMEPAGE="http://"
+
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+
+}
+