aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-01-09 16:17:04 +0000
committerRobert Piasek <dagger@gentoo.org>2009-01-09 16:17:04 +0000
commit6148701714b9d10fc51cf9eb503673f84b767bc0 (patch)
tree66518c473a10185bae8de12afa08601d144b158a /x11-wm
parentTesing svn access (diff)
downloadembedded-cross-6148701714b9d10fc51cf9eb503673f84b767bc0.tar.gz
embedded-cross-6148701714b9d10fc51cf9eb503673f84b767bc0.tar.bz2
embedded-cross-6148701714b9d10fc51cf9eb503673f84b767bc0.zip
Initial upload of openmoko-target
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/e/Manifest4
-rw-r--r--x11-wm/e/e-20081014.ebuild65
-rw-r--r--x11-wm/e/e-20081210.ebuild72
-rw-r--r--x11-wm/e/e-20090108.ebuild77
-rw-r--r--x11-wm/e/files/applications.menu105
5 files changed, 323 insertions, 0 deletions
diff --git a/x11-wm/e/Manifest b/x11-wm/e/Manifest
new file mode 100644
index 0000000..9a5d376
--- /dev/null
+++ b/x11-wm/e/Manifest
@@ -0,0 +1,4 @@
+AUX applications.menu 2267 RMD160 812c2384ccbd6e0403c593ca7cd9295f15a22fcd SHA1 5a83b3f38fdf605cbe40809a9b5c70e1e3c62ba1 SHA256 f3d7dda0693bc51be70acb267fb5b5183c9dffc05c37d13cb6b1ced66d1c61f8
+EBUILD e-20081014.ebuild 1441 RMD160 e93e2cee7b3ed55366a54eb7fd61644e6b2cde04 SHA1 97b371a921cec7c54a5a511d5295177fa33ceccd SHA256 2e9ac82dd2cfd450d1868febca88d078502760a4a564271c0c77642589ccb740
+EBUILD e-20081210.ebuild 1626 RMD160 a8c9404bdf805d372f4ba7ccfefc71bb619111fc SHA1 fa8936182419ddee224d08743c2b90e722c9bd7f SHA256 29874c7c3cf911272d7dd7cf668dd467398276ed87846046122c39bcb980cb3d
+EBUILD e-20090108.ebuild 1755 RMD160 d2df810d8fe1a9f0fe0908669f84441d1f332821 SHA1 84d4f8d927307fbf7c8982dc1f497c17c0b7d250 SHA256 c99a0b0a945f440efa9b1506d2242de580ae1a2161c0150c155adcb86113f3da
diff --git a/x11-wm/e/e-20081014.ebuild b/x11-wm/e/e-20081014.ebuild
new file mode 100644
index 0000000..e3837fd
--- /dev/null
+++ b/x11-wm/e/e-20081014.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Enlightenment E17 window manager"
+HOMEPAGE="http://www.enlightenment.org/"
+ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/${PN}"
+ESVN_REVISION="r36661"
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="X alsa dbus nls files"
+
+inherit autotools subversion
+
+RDEPEND="dev-libs/eina
+ x11-libs/ecore
+ dev-libs/eet
+ dbus? ( x11-libs/e_dbus )
+ X? ( x11-libs/libX11 )
+ alsa? ( media-libs/alsa-lib )"
+
+DEPEND=">=dev-util/pkgconfig-0.9.0
+ media-libs/edje"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if use dbus && ! built_with_use x11-libs/e_dbus hal; then
+ die "Please rebuild x11-libs/e_dbus with the hal use flag enabled!"
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+
+ cd "${S}"
+
+ touch README
+ touch ABOUT-NLS
+ autopoint -f || die "autopoint faile"
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} \
+ $(use_enable alsa) \
+ $(use_enable files) \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --x-includes=${SYSROOT}/usr/X11R6/include \
+ --x-libraries=${SYSROOT}/usr/X11R6/lib\
+ --with-edje-cc=/usr/bin/edje_cc\
+ --with-eet-eet=/usr/bin/eet"
+
+ econf $myconf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+}
diff --git a/x11-wm/e/e-20081210.ebuild b/x11-wm/e/e-20081210.ebuild
new file mode 100644
index 0000000..496e523
--- /dev/null
+++ b/x11-wm/e/e-20081210.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Enlightenment E17 window manager"
+HOMEPAGE="http://www.enlightenment.org/"
+ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/${PN}"
+ESVN_REVISION="r38100"
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="X alsa dbus nls files pam"
+
+inherit autotools subversion
+
+RDEPEND="dev-libs/eet
+ =dev-libs/eina-20081211
+ =dev-libs/efreet-20081114
+ =x11-libs/ecore-20081212
+ =x11-libs/evas-20081212
+ >=media-libs/edje-0.5.0
+ dbus? ( =x11-libs/e_dbus-20081209 )
+ X? ( x11-libs/libX11 )
+ alsa? ( media-libs/alsa-lib )
+ pam? ( sys-libs/pam )"
+
+DEPEND=">=dev-util/pkgconfig-0.9.0
+ media-libs/edje
+ dev-util/cvs"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if use dbus && ! built_with_use x11-libs/e_dbus hal; then
+ die "Please rebuild x11-libs/e_dbus with the hal use flag enabled!"
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+
+ cd "${S}"
+
+ touch README
+ touch ABOUT-NLS
+
+ autopoint -f || die "autopoint failed"
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} \
+ $(use_enable alsa) \
+ $(use_enable files) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_with X x) \
+ --x-includes=${SYSROOT}/usr/X11R6/include \
+ --x-libraries=${SYSROOT}/usr/X11R6/lib\
+ --with-edje-cc=/usr/bin/edje_cc\
+ --with-eet-eet=/usr/bin/eet"
+
+ econf $myconf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+}
diff --git a/x11-wm/e/e-20090108.ebuild b/x11-wm/e/e-20090108.ebuild
new file mode 100644
index 0000000..4838d18
--- /dev/null
+++ b/x11-wm/e/e-20090108.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Enlightenment E17 window manager"
+HOMEPAGE="http://www.enlightenment.org/"
+ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/${PN}"
+ESVN_REVISION="r38500"
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="X alsa dbus nls files pam"
+
+inherit autotools subversion
+
+RDEPEND="dev-libs/eet
+ =dev-libs/eina-20090108
+ =dev-libs/efreet-20090108
+ =x11-libs/ecore-20090108
+ =x11-libs/evas-20090108
+ >=media-libs/edje-0.5.0
+ dbus? ( =x11-libs/e_dbus-20090108 )
+ X? ( x11-libs/libX11 )
+ alsa? ( media-libs/alsa-lib )
+ pam? ( sys-libs/pam )"
+
+DEPEND=">=dev-util/pkgconfig-0.9.0
+ media-libs/edje
+ dev-util/cvs"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if use dbus && ! built_with_use x11-libs/e_dbus hal; then
+ die "Please rebuild x11-libs/e_dbus with the hal use flag enabled!"
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+
+ cd "${S}"
+
+ touch README
+ touch ABOUT-NLS
+
+ autopoint -f || die "autopoint failed"
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} \
+ $(use_enable alsa) \
+ $(use_enable files) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_with X x) \
+ --x-includes=${SYSROOT}/usr/X11R6/include \
+ --x-libraries=${SYSROOT}/usr/X11R6/lib\
+ --with-edje-cc=/usr/bin/edje_cc\
+ --with-eet-eet=/usr/bin/eet"
+
+ econf $myconf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+
+ keepdir /etc/xdg/menus
+ insinto /etc/xdg/menus
+ newins "${FILESDIR}/applications.menu" applications.menu
+
+}
diff --git a/x11-wm/e/files/applications.menu b/x11-wm/e/files/applications.menu
new file mode 100644
index 0000000..77c6f04
--- /dev/null
+++ b/x11-wm/e/files/applications.menu
@@ -0,0 +1,105 @@
+<?xml version="1.0"?>
+<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN" "http://standards.freedesktop.org/menu-spec/menu-1.0.dtd">
+<Menu>
+ <Name>Applications</Name>
+ <!-- <Directory>Applications.directory</Directory> -->
+
+ <!-- Read standard .directory and .desktop file locations -->
+ <DefaultAppDirs>/usr/share/applications</DefaultAppDirs>
+ <DefaultDirectoryDirs/>
+
+ <Menu>
+ <Name>Office</Name>
+ <Directory>Office.directory</Directory>
+ <Include>
+ <And>
+ <Category>Office</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Multimedia</Name>
+ <Directory>Multimedia.directory</Directory>
+ <Include>
+ <And>
+ <Category>AudioVideo</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Graphics</Name>
+ <Directory>Graphics.directory</Directory>
+ <Include>
+ <And>
+ <Category>Graphics</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Games</Name>
+ <Directory>Games.directory</Directory>
+ <Include>
+ <And>
+ <Or>
+ <Category>Game</Category>
+ <Category>Games</Category>
+ </Or>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Internet</Name>
+ <Directory>Internet.directory</Directory>
+ <Include>
+ <And>
+ <Or>
+ <Category>Internet</Category>
+ <Category>Network</Category>
+ </Or>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Settings</Name>
+ <Directory>Settings.directory</Directory>
+ <Include>
+ <And>
+ <Or>
+ <Category>SystemSettings</Category>
+ <Category>Settings</Category>
+ </Or>
+ <Not>
+ <Category>System</Category>
+ </Not>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Accessories</Name>
+ <Directory>Accessories.directory</Directory>
+ <Include>
+ <And>
+ <Or>
+ <Category>Applications</Category>
+ <Category>Utility</Category>
+ </Or>
+ <Not>
+ <Category>System</Category>
+ <Category>Office</Category>
+ <Category>Internet</Category>
+ <Category>AudioVideo</Category>
+ <Category>Graphics</Category>
+ <Category>Games</Category>
+ </Not>
+ </And>
+ </Include>
+ </Menu>
+
+</Menu>
+