summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Seifert <dev@erichseifert.de>2012-04-10 22:51:59 +0200
committerErich Seifert <dev@erichseifert.de>2012-04-10 22:51:59 +0200
commitb5abea0e2b18272309f3b6ffe678ffc83d0ba378 (patch)
tree9db5b452df167d24f3d10887ef0794c1c724a10f
parent[Documentation] more explicit bug text instructions (diff)
downloadprinter-drivers-b5abea0e2b18272309f3b6ffe678ffc83d0ba378.tar.gz
printer-drivers-b5abea0e2b18272309f3b6ffe678ffc83d0ba378.tar.bz2
printer-drivers-b5abea0e2b18272309f3b6ffe678ffc83d0ba378.zip
Inital commit. Added ebuilds for Brother MFC-6490CW and Brother license.
-rw-r--r--licenses/Brother30
-rw-r--r--net-print/brother-mfc6490cw-cups/Manifest1
-rw-r--r--net-print/brother-mfc6490cw-cups/brother-mfc6490cw-cups-1.1.2_p2.ebuild87
-rw-r--r--net-print/brother-mfc6490cw-cups/metadata.xml12
-rw-r--r--net-print/brother-mfc6490cw-lpr/Manifest1
-rw-r--r--net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild32
-rw-r--r--net-print/brother-mfc6490cw-lpr/metadata.xml9
7 files changed, 172 insertions, 0 deletions
diff --git a/licenses/Brother b/licenses/Brother
new file mode 100644
index 0000000..e064c18
--- /dev/null
+++ b/licenses/Brother
@@ -0,0 +1,30 @@
+Brother License Agreement
+
+Brother retains any and all copyrights to the Software. In no case this
+Agreement shall be construed to assign or otherwise transfer from Brother to
+User any copyrights or other intellectual property rights to whole or any part
+of the Software.
+
+Brother grants User a non-exclusive license: to reproduce and/or distribute
+(via Internet or in any other manner) the Software. Further, Brother grants
+User a non-exclusive license to modify, alter, translate or otherwise prepare
+derivative works of the Software and to reproduce and distribute (via Internet
+or in any other manner) such modification, alteration, translation or other
+derivative works for any purpose.
+
+The license of the Software from Brother hereunder is granted "AS IS." BROTHER
+HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY,
+MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT.
+Brother shall have no liability in contract, tort (including negligence or
+breach of statutory duty) or otherwise for any interruption of use, loss of
+data, or for any indirect, incidental, punitive or consequential loss or
+damage, or for any loss of profit, revenue, data, goodwill or anticipated
+savings that arises under, out of, or in contemplation of this Agreement or
+otherwise arises due to any error, inaccuracy or defect in the Software even if
+Brother has been advised of the possibility of such loss or damage.
+Further, Brother shall have no liability to disclose and/or distribute the
+source cord of the Software to User under any circumstances. In no case shall
+the above license by Brother to modify, alter, translate or otherwise prepare
+derivative works of the Software be construed as Brother's implied agreement or
+undertakings to disclose and/or distribute the source cord of the Software.
diff --git a/net-print/brother-mfc6490cw-cups/Manifest b/net-print/brother-mfc6490cw-cups/Manifest
new file mode 100644
index 0000000..194985d
--- /dev/null
+++ b/net-print/brother-mfc6490cw-cups/Manifest
@@ -0,0 +1 @@
+DIST mfc6490cwcupswrapper-1.1.2-2.i386.rpm 15650 SHA256 c3c84a4c6a51660873099ff3cc8bb0aa82dc57bffa721a91b1081116a5ab900c SHA512 e3486096f8ddbdba2c46ce13f70a9936ffb8184045cc7a99402068861ee6b214b778515ef786df07ec600b327fc1f901ff961664344488603bb2179162399ed9 WHIRLPOOL b32bb4dd6eb0e6d8b118068ed28879052093c70e15a1de3109493549b6d870e301a24efab183e63199007ebfb79a84d49e1b260ca1f041e6f9cdd088636b3922
diff --git a/net-print/brother-mfc6490cw-cups/brother-mfc6490cw-cups-1.1.2_p2.ebuild b/net-print/brother-mfc6490cw-cups/brother-mfc6490cw-cups-1.1.2_p2.ebuild
new file mode 100644
index 0000000..76cad30
--- /dev/null
+++ b/net-print/brother-mfc6490cw-cups/brother-mfc6490cw-cups-1.1.2_p2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit rpm
+
+MY_PN="${PN/brother-/}"
+MY_PN="${MY_PN/-cups/}"
+MY_PV="${PV/_p/-}"
+
+DESCRIPTION="CUPS driver for Brother MFC-6490CW"
+HOMEPAGE="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html"
+SRC_URI="http://www.brother.com/pub/bsc/linux/dlf/${MY_PN}cupswrapper-${MY_PV}.i386.rpm"
+RESTRICT="mirror strip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="net-print/cups
+ app-text/psutils
+ net-print/brother-${MY_PN}-lpr"
+DEPEND="net-print/cups"
+
+S="${WORKDIR}"
+INSTALL_SCRIPT="${S}/usr/local/Brother/Printer/${MY_PN}/cupswrapper/cupswrapper${MY_PN}"
+PPD_PATH="${S}/usr/share/cups/model"
+FILTER_PATH="${S}/usr/lib/cups/filter"
+
+src_prepare() {
+ local installScriptNew="${S}/install.sh"
+
+ echo '#!/bin/sh' >"${installScriptNew}"
+
+ egrep '(printer_model|printer_name|device_name|pcfilename|device_model)=' "${INSTALL_SCRIPT}" >>"${installScriptNew}" || die "Extracting variables failed"
+
+ echo "ppd_file_name=${PPD_PATH}/br\${printer_model}.ppd" >>"${installScriptNew}"
+ sed -n '/cat <<ENDOFPPDFILE1/,/ENDOFPPDFILE1/p' "${INSTALL_SCRIPT}" >>"${installScriptNew}" || die "Creating PPD file failed"
+
+ echo "brotherlpdwrapper=${FILTER_PATH}/brlpdwrapper\${printer_model}" >>"${installScriptNew}"
+ sed -n '/cat <<!ENDOFWFILTER!/,/!ENDOFWFILTER!/p' "${INSTALL_SCRIPT}" >>"${installScriptNew}" || die "Creating filter wrapper failed"
+
+ # Overwrite original INSTALL script
+ mv "${installScriptNew}" "${INSTALL_SCRIPT}"
+
+ mkdir -p "${PPD_PATH}"
+ mkdir -p "${FILTER_PATH}"
+ "/bin/sh" "${INSTALL_SCRIPT}" || die "Installation failed"
+
+}
+
+src_configure() {
+ if use debug; then
+ sed -i -e 's:^\(DEBUG\)=0:\1=1:' "${FILTER_PATH}/brlpdwrapper"* || die "Enabling debug output failed"
+ fi
+}
+
+src_install() {
+ rm -f "${INSTALL_SCRIPT}" || die
+ insinto "/usr/local"
+ doins -r "usr/local/Brother" || die
+ fperms -R 755 "/usr/local/Brother" || die
+
+ insinto "/usr/share/cups"
+ doins -r "${PPD_PATH}" || die
+
+ insinto "/usr/libexec/cups"
+ doins -r "${FILTER_PATH}" || die
+ fperms -R 755 "/usr/libexec/cups/filter" || die
+}
+
+pkg_postinst() {
+ ewarn "Printer setup required"
+ elog "Use the brprintconf_${MY_PN} command to change printer options."
+ elog "For example, set the paper type to A4 right after installation"
+ elog "otherwise your prints will be misaligned!"
+ elog
+ elog "To set A4 paper type:"
+ elog " brprintconf_${MY_PN} -pt A4"
+ elog "To set quality to 'Fast Normal':"
+ elog " brprintconf_${MY_PN} -reso 300x300dpi"
+ elog "To get an overview of all available options:"
+ elog " brprintconf_${MY_PN}"
+}
diff --git a/net-print/brother-mfc6490cw-cups/metadata.xml b/net-print/brother-mfc6490cw-cups/metadata.xml
new file mode 100644
index 0000000..f50623f
--- /dev/null
+++ b/net-print/brother-mfc6490cw-cups/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <maintainer>
+ <email>dev@erichseifert.de</email>
+ <name>Erich Seifert</name>
+ </maintainer>
+ <use>
+ <flag name="debug">Enable debugging output for CUPS wrapper</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-print/brother-mfc6490cw-lpr/Manifest b/net-print/brother-mfc6490cw-lpr/Manifest
new file mode 100644
index 0000000..645a5ec
--- /dev/null
+++ b/net-print/brother-mfc6490cw-lpr/Manifest
@@ -0,0 +1 @@
+DIST mfc6490cwlpr-1.1.2-2.i386.rpm 1908851 SHA256 2238291b0bb72e23a80813e3a280c7e0ad88407a24f5f4849e6b14ef3c6888d9 SHA512 547a0f229f554181bab67ce4fc4a51b38e5f50d9877f85c15eb8b9e2aa1f100e4042399fda5d6c4e0f1e19f223e38a32bb290800a9fcebd4c2cea323dce4d8a6 WHIRLPOOL 2e631048324124d4f4618f5cf756c5a9a94f3812b21e2f7a9f1f5a15585b33c07173f08dab663ed91e4766dc04454872d8008eed39b3c5d40550162b45ce193c
diff --git a/net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild b/net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild
new file mode 100644
index 0000000..bd8df76
--- /dev/null
+++ b/net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit rpm
+
+MY_PN="${PN/brother-/}"
+MY_PN="${MY_PN/-lpr/}"
+MY_PV="${PV/_p/-}"
+
+DESCRIPTION="LPR driver for Brother MFC-6490CW"
+HOMEPAGE="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html"
+SRC_URI="http://www.brother.com/pub/bsc/linux/dlf/${MY_PN}lpr-${MY_PV}.i386.rpm"
+RESTRICT="mirror strip"
+
+LICENSE="Brother"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( net-print/cups net-print/lprng )
+ app-text/ghostscript-gpl
+ app-text/a2ps"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ cp -R "${S}"/* "${D}"/ || die "Install failed"
+}
diff --git a/net-print/brother-mfc6490cw-lpr/metadata.xml b/net-print/brother-mfc6490cw-lpr/metadata.xml
new file mode 100644
index 0000000..caf8b3a
--- /dev/null
+++ b/net-print/brother-mfc6490cw-lpr/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <maintainer>
+ <email>dev@erichseifert.de</email>
+ <name>Erich Seifert</name>
+ </maintainer>
+</pkgmetadata>