summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/g15composer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/g15composer')
-rw-r--r--app-misc/g15composer/Manifest2
-rw-r--r--app-misc/g15composer/files/g15composer-3.1.confd17
-rw-r--r--app-misc/g15composer/files/g15composer-3.1.initd49
-rw-r--r--app-misc/g15composer/files/g15composer-3.2.confd17
-rw-r--r--app-misc/g15composer/files/g15composer-3.2.initd49
-rw-r--r--app-misc/g15composer/g15composer-3.1.ebuild42
-rw-r--r--app-misc/g15composer/g15composer-3.2.ebuild42
-rw-r--r--app-misc/g15composer/metadata.xml14
8 files changed, 232 insertions, 0 deletions
diff --git a/app-misc/g15composer/Manifest b/app-misc/g15composer/Manifest
new file mode 100644
index 000000000000..afeed3970c6e
--- /dev/null
+++ b/app-misc/g15composer/Manifest
@@ -0,0 +1,2 @@
+DIST g15composer-3.1.tar.bz2 104109 SHA256 d8f34c1711e95f8ca3ddd9fd5f557a51bb23b79099fbf2fddb96bdcd03067988 SHA512 e4b0ddef2dfbfd3a8a392ebe9e53a59638cbb7aee7a007b8a20be388f074d54a27ed509a5805fadc9ffd708c027ec4c331dfab96905bee1c37690a5585198ad8 WHIRLPOOL 3921267bfd884860d4228a8ec5546a536547c1a78bb287bd9dfe0d78029a4006bf87a8f47c6eeca4b9b22dcd05f565ca990d688dcdbe119706e9cec4857a5e90
+DIST g15composer-3.2.tar.bz2 105805 SHA256 0ae3fdac1dd5858bb7185ae5a50a6ff1c657a29d02b44c8a73f1c38cec17b035 SHA512 95b033e2bb957ef4a2f3d3e2954a11454af7d8576e037f723d2a7d45a7dadde4908540ff0a66b387209e689217ba0e6677dcee1e647b792c402f250371518bc1 WHIRLPOOL 4553fd85ff8627f8c31ec66799f39138c63b487c4a584e726e6a2f5f58f1ff9405afff4c5b7d1b020ac1a4fbd25b678fa5c043e2d099409238e01ba1a8a71729
diff --git a/app-misc/g15composer/files/g15composer-3.1.confd b/app-misc/g15composer/files/g15composer-3.1.confd
new file mode 100644
index 000000000000..f42ab956e242
--- /dev/null
+++ b/app-misc/g15composer/files/g15composer-3.1.confd
@@ -0,0 +1,17 @@
+# /etc/conf.d/g15composer: Configuration for the g15composer
+
+# The CONTROL_FIFO is the name of the FIFO that g15composer listens to.
+# It does not create a screen on the display, but allows programs to
+# create their own non-virtual screens.
+# Please make sure the file specified does not exist.
+CONTROL_FIFO="/var/run/g15composer"
+
+# Set the user who owns the CONTROL_FIFO.
+# As this is also the user as whom g15composer is run,
+# it has to be someone who can create further message channels
+# This should be the user who runs the LCD clients
+FIFO_USER=
+
+# Set the grop which owns the CONTROL_FIFO.
+# The users who want to display screens on the LCD need to be in this group.
+FIFO_GROUP=users
diff --git a/app-misc/g15composer/files/g15composer-3.1.initd b/app-misc/g15composer/files/g15composer-3.1.initd
new file mode 100644
index 000000000000..15fd4963ba4c
--- /dev/null
+++ b/app-misc/g15composer/files/g15composer-3.1.initd
@@ -0,0 +1,49 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PIDFILE=/var/run/${SVCNAME}.pid
+
+depend() {
+ need g15daemon
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+
+ if [ -z "${FIFO_USER}" -o -z "${FIFO_GROUP}" ] ; then
+ eerror "Please set the FIFO_USER and FIFO_GROUP variables in /etc/conf.d/${SVCNAME}"
+ eend 1
+ return 1
+ fi
+ if [ -e "${CONTROL_FIFO}" -a ! -p "${CONTROL_FIFO}" ] ; then
+ eerror "${CONTROL_FIFO} exists and is not a FIFO. Please remove."
+ eend 1
+ return 1
+ fi
+ if [ ! -p "${CONTROL_FIFO}" ] ; then
+ einfo "Creating FIFO at ${CONTROL_FIFO}"
+ mkfifo -m660 "${CONTROL_FIFO}"
+ else
+ einfo "Reusing FIFO at ${CONTROL_FIFO}"
+ fi
+
+ chown ${FIFO_USER} "${CONTROL_FIFO}"
+ chgrp ${FIFO_GROUP} "${CONTROL_FIFO}"
+ start-stop-daemon --start --background --pidfile ${PIDFILE} --make-pidfile --exec \
+ /usr/bin/g15composer -- -b -u "${FIFO_USER}" -g "${FIFO_GROUP}" "${CONTROL_FIFO}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stoping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile ${PIDFILE} --name g15composer
+ if [ -p "${CONTROL_FIFO}" ] ; then
+ einfo "Removing FIFO at ${CONTROL_FIFO}"
+ rm -f "${CONTROL_FIFO}"
+ else
+ ewarn "FIFO at ${CONTROL_FIFO} was lost"
+ fi
+ eend $?
+}
diff --git a/app-misc/g15composer/files/g15composer-3.2.confd b/app-misc/g15composer/files/g15composer-3.2.confd
new file mode 100644
index 000000000000..f42ab956e242
--- /dev/null
+++ b/app-misc/g15composer/files/g15composer-3.2.confd
@@ -0,0 +1,17 @@
+# /etc/conf.d/g15composer: Configuration for the g15composer
+
+# The CONTROL_FIFO is the name of the FIFO that g15composer listens to.
+# It does not create a screen on the display, but allows programs to
+# create their own non-virtual screens.
+# Please make sure the file specified does not exist.
+CONTROL_FIFO="/var/run/g15composer"
+
+# Set the user who owns the CONTROL_FIFO.
+# As this is also the user as whom g15composer is run,
+# it has to be someone who can create further message channels
+# This should be the user who runs the LCD clients
+FIFO_USER=
+
+# Set the grop which owns the CONTROL_FIFO.
+# The users who want to display screens on the LCD need to be in this group.
+FIFO_GROUP=users
diff --git a/app-misc/g15composer/files/g15composer-3.2.initd b/app-misc/g15composer/files/g15composer-3.2.initd
new file mode 100644
index 000000000000..15fd4963ba4c
--- /dev/null
+++ b/app-misc/g15composer/files/g15composer-3.2.initd
@@ -0,0 +1,49 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PIDFILE=/var/run/${SVCNAME}.pid
+
+depend() {
+ need g15daemon
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+
+ if [ -z "${FIFO_USER}" -o -z "${FIFO_GROUP}" ] ; then
+ eerror "Please set the FIFO_USER and FIFO_GROUP variables in /etc/conf.d/${SVCNAME}"
+ eend 1
+ return 1
+ fi
+ if [ -e "${CONTROL_FIFO}" -a ! -p "${CONTROL_FIFO}" ] ; then
+ eerror "${CONTROL_FIFO} exists and is not a FIFO. Please remove."
+ eend 1
+ return 1
+ fi
+ if [ ! -p "${CONTROL_FIFO}" ] ; then
+ einfo "Creating FIFO at ${CONTROL_FIFO}"
+ mkfifo -m660 "${CONTROL_FIFO}"
+ else
+ einfo "Reusing FIFO at ${CONTROL_FIFO}"
+ fi
+
+ chown ${FIFO_USER} "${CONTROL_FIFO}"
+ chgrp ${FIFO_GROUP} "${CONTROL_FIFO}"
+ start-stop-daemon --start --background --pidfile ${PIDFILE} --make-pidfile --exec \
+ /usr/bin/g15composer -- -b -u "${FIFO_USER}" -g "${FIFO_GROUP}" "${CONTROL_FIFO}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stoping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile ${PIDFILE} --name g15composer
+ if [ -p "${CONTROL_FIFO}" ] ; then
+ einfo "Removing FIFO at ${CONTROL_FIFO}"
+ rm -f "${CONTROL_FIFO}"
+ else
+ ewarn "FIFO at ${CONTROL_FIFO} was lost"
+ fi
+ eend $?
+}
diff --git a/app-misc/g15composer/g15composer-3.1.ebuild b/app-misc/g15composer/g15composer-3.1.ebuild
new file mode 100644
index 000000000000..2856e6a08064
--- /dev/null
+++ b/app-misc/g15composer/g15composer-3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A library to render text and shapes into a buffer usable by the Logitech G15 keyboard"
+HOMEPAGE="http://g15tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="truetype examples"
+
+DEPEND="app-misc/g15daemon
+ >=dev-libs/libg15render-1.2[truetype?]
+ truetype? ( media-libs/freetype )"
+
+src_configure() {
+ econf \
+ $(use_enable truetype ttf)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}/${P}.initd" ${PN}
+ newconfd "${FILESDIR}/${P}.confd" ${PN}
+
+ dodoc AUTHORS README ChangeLog
+
+ if use examples ; then
+ exeinto "/usr/share/${PN}"
+ doexe examples/*
+ fi
+}
+
+pkg_postinst() {
+ elog "Set the user to run g15composer in /etc/conf.d/g15composer before starting the service."
+}
diff --git a/app-misc/g15composer/g15composer-3.2.ebuild b/app-misc/g15composer/g15composer-3.2.ebuild
new file mode 100644
index 000000000000..8026fad9a88f
--- /dev/null
+++ b/app-misc/g15composer/g15composer-3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A library to render text and shapes into a buffer usable by the Logitech G15 keyboard"
+HOMEPAGE="http://g15tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="truetype examples"
+
+DEPEND="app-misc/g15daemon
+ >=dev-libs/libg15render-1.2[truetype?]
+ truetype? ( media-libs/freetype )"
+
+src_configure() {
+ econf \
+ $(use_enable truetype ttf)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}/${P}.initd" ${PN}
+ newconfd "${FILESDIR}/${P}.confd" ${PN}
+
+ dodoc AUTHORS README ChangeLog
+
+ if use examples ; then
+ exeinto "/usr/share/${PN}"
+ doexe examples/*
+ fi
+}
+
+pkg_postinst() {
+ elog "Set the user to run g15composer in /etc/conf.d/g15composer before starting the service."
+}
diff --git a/app-misc/g15composer/metadata.xml b/app-misc/g15composer/metadata.xml
new file mode 100644
index 000000000000..968a455eb0aa
--- /dev/null
+++ b/app-misc/g15composer/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">g15tools</remote-id>
+ </upstream>
+</pkgmetadata>