summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-24 14:23:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-24 14:46:03 +0200
commitf7550f6f7a762e8e472f6b6027b22e1eea4390ed (patch)
treee2deee87adf6116ddb8a31f1fe6fa405bc68911c /dev-python/tifffile/tifffile-2024.7.24.ebuild
parentdev-python/sentry-sdk: Bump to 2.11.0 (diff)
downloadgentoo-f7550f6f7a762e8e472f6b6027b22e1eea4390ed.tar.gz
gentoo-f7550f6f7a762e8e472f6b6027b22e1eea4390ed.tar.bz2
gentoo-f7550f6f7a762e8e472f6b6027b22e1eea4390ed.zip
dev-python/tifffile: Bump to 2024.7.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile/tifffile-2024.7.24.ebuild')
-rw-r--r--dev-python/tifffile/tifffile-2024.7.24.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tifffile/tifffile-2024.7.24.ebuild b/dev-python/tifffile/tifffile-2024.7.24.ebuild
new file mode 100644
index 000000000000..190a5b9ccada
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.7.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}