summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 09:37:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 10:40:26 +0100
commit370b1e5d073539f2a29a44edf2714929653e9c8a (patch)
treeb5a3971b374e4805f1139b7f26b2dc89ec0578e3 /dev-python/xmlschema/xmlschema-1.8.2.ebuild
parentdev-python/phonenumbers: Bump to 8.12.37 (diff)
downloadgentoo-370b1e5d073539f2a29a44edf2714929653e9c8a.tar.gz
gentoo-370b1e5d073539f2a29a44edf2714929653e9c8a.tar.bz2
gentoo-370b1e5d073539f2a29a44edf2714929653e9c8a.zip
dev-python/xmlschema: Bump to 1.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema/xmlschema-1.8.2.ebuild')
-rw-r--r--dev-python/xmlschema/xmlschema-1.8.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/xmlschema/xmlschema-1.8.2.ebuild b/dev-python/xmlschema/xmlschema-1.8.2.ebuild
new file mode 100644
index 000000000000..4860e6037578
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.3.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}