summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYang Yang <geraint0923@gmail.com>2021-11-01 10:27:05 -0700
committerAmy Liffey <amynka@gentoo.org>2021-11-08 19:23:33 +0100
commit37b18c77e0c5b7705f5f6a45ea99ba897a3c0d70 (patch)
tree2f166833f154bf3dd1cdb212243cc35fc8a768db /net-misc/mosh
parentdev-util/woke: 0.16.1 bump (diff)
downloadgentoo-37b18c77e0c5b7705f5f6a45ea99ba897a3c0d70.tar.gz
gentoo-37b18c77e0c5b7705f5f6a45ea99ba897a3c0d70.tar.bz2
gentoo-37b18c77e0c5b7705f5f6a45ea99ba897a3c0d70.zip
net-misc/mosh: add patch to enable the compilation with clang
Fix is introduced to mosh official at: https://github.com/mobile-shell/mosh/commit/e5f8a826ef9ff5da4cfce3bb8151f9526ec19db0 Closes: https://github.com/gentoo/gentoo/pull/22787 Signed-off-by: Yang Yang <geraint0923@gmail.com> Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'net-misc/mosh')
-rw-r--r--net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch11
-rw-r--r--net-misc/mosh/mosh-1.3.2-r2.ebuild (renamed from net-misc/mosh/mosh-1.3.2-r1.ebuild)1
2 files changed, 12 insertions, 0 deletions
diff --git a/net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch b/net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch
new file mode 100644
index 000000000000..0203cfff6b23
--- /dev/null
+++ b/net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch
@@ -0,0 +1,11 @@
+--- a/src/network/network.cc
++++ b/src/network/network.cc
+@@ -335,7 +335,7 @@ bool Connection::try_bind( const char *addr, int port_low, int port_high )
+ }
+ }
+
+- if ( bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
++ if ( ::bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
+ set_MTU( local_addr.sa.sa_family );
+ return true;
+ } else if ( i == search_high ) { /* last port to search */
diff --git a/net-misc/mosh/mosh-1.3.2-r1.ebuild b/net-misc/mosh/mosh-1.3.2-r2.ebuild
index 469c7b1f214b..710a8c1fe272 100644
--- a/net-misc/mosh/mosh-1.3.2-r1.ebuild
+++ b/net-misc/mosh/mosh-1.3.2-r2.ebuild
@@ -37,6 +37,7 @@ DEPEND="${RDEPEND}
# [0] - avoid sandbox-violation calling git describe in Makefile.
PATCHES=(
"${FILESDIR}"/${PN}-1.2.5-git-version.patch
+ "${FILESDIR}"/${P}-bind-misinterpret.patch
)
src_prepare() {