summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-06 10:37:13 +0000
committerSam James <sam@gentoo.org>2024-11-06 10:46:51 +0000
commit585c470519cdd7f0b27dd465d96f8a7b3ed03b59 (patch)
treed96d505f8da89af4accdb316575031e4e5a3e79e /net-misc/nyx/nyx-2.1.0-r7.ebuild
parentnet-misc/nyx: cleanup a bit (diff)
downloadgentoo-585c470519cdd7f0b27dd465d96f8a7b3ed03b59.tar.gz
gentoo-585c470519cdd7f0b27dd465d96f8a7b3ed03b59.tar.bz2
gentoo-585c470519cdd7f0b27dd465d96f8a7b3ed03b59.zip
net-misc/nyx: fix Python 3.11 compat
Closes: https://bugs.gentoo.org/942871 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/nyx/nyx-2.1.0-r7.ebuild')
-rw-r--r--net-misc/nyx/nyx-2.1.0-r7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/nyx/nyx-2.1.0-r7.ebuild b/net-misc/nyx/nyx-2.1.0-r7.ebuild
new file mode 100644
index 000000000000..c980ee277f0c
--- /dev/null
+++ b/net-misc/nyx/nyx-2.1.0-r7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE='ncurses,sqlite(-)'
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+ inherit pypi
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ net-libs/stem[${PYTHON_USEDEP}]
+ net-vpn/tor
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-py311.patch
+)
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # bug #645336
+ doman nyx.1
+}