summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/gmapping/Manifest1
-rw-r--r--dev-ros/gmapping/gmapping-1.4.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/gmapping/Manifest b/dev-ros/gmapping/Manifest
index 89868892f12e..60b37799cb77 100644
--- a/dev-ros/gmapping/Manifest
+++ b/dev-ros/gmapping/Manifest
@@ -1 +1,2 @@
DIST slam_gmapping-1.3.10.tar.gz 21032 BLAKE2B cca0779e64d45622dad4ec29cb3c1d0162176038288c0aa7b117f1a76a7655f3af3024dba7ff1025948e400e0176794a553e357a235187d9196161a635ab6d01 SHA512 fa4485ddc9fcfaac63a63d209a5a994e33e78546a39edcf47eb3c3f1775f0d87a1f562319058868838990bbf85a9515ff0228779dce7531148f208b3522e7e7a
+DIST slam_gmapping-1.4.0.tar.gz 21123 BLAKE2B 088d1bfaa69bf98eb2b2176afbfadf843f5f478f9c54dc7eb32fa91116da31bab66f9a1ac09d0535629cc5a7f604d153c90c5a25f173fb867369aa9e33d4d7b2 SHA512 ae7984716113e24e1bced88523729481829303a2b88d247b8fc8bdd23c0f38b4ce6260d7086d79a6653ecfdbe8ba60ae011af20180ffcb5025cd9d347d3e76b1
diff --git a/dev-ros/gmapping/gmapping-1.4.0.ebuild b/dev-ros/gmapping/gmapping-1.4.0.ebuild
new file mode 100644
index 000000000000..307f03f929b1
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+ dev-ros/gmapping
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest"