summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libfishsound/libfishsound-1.0.0.ebuild')
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/libfishsound/libfishsound-1.0.0.ebuild b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
new file mode 100644
index 000000000000..897e70462c48
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Simple programming interface for decoding and encoding audio data using vorbis or speex"
+HOMEPAGE="http://www.xiph.org/fishsound/"
+SRC_URI="http://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="flac speex"
+
+RDEPEND="media-libs/libvorbis
+ media-libs/libogg
+ flac? ( media-libs/flac )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# bug #395153
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-pc.patch
+ sed -i \
+ -e 's:doxygen:doxygen-dummy:' \
+ configure || die
+}
+
+src_configure() {
+ local myconf=""
+ use flac || myconf="${myconf} --disable-flac"
+ use speex || myconf="${myconf} --disable-speex"
+
+ econf \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${D}/usr/share/doc/${PF}" install || die
+ dodoc AUTHORS ChangeLog README
+}